HDU1284——钱币兑换问题【dp】

钱币兑换问题

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14528    Accepted Submission(s): 8784

 

Problem Description

在一个国家仅有1分,2分,3分硬币,将钱N兑换成硬币有很多种兑法。请你编程序计算出共有多少种兑法。

Input

每行只有一个正整数N,N小于32768。

Output

对应每个输入,输出兑换方法数。

Sample Input

2934

12553

 Sample Output

718831

13137761

 Author

SmallBeer(CML)

解题思路:

方法一:

用 dp[i][j] 来代表使用前 i 种硬币组成 j 的方案数,可以推出:

dp[i][j] = dp[i-1][j] + dp[i][j-i];

代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <set>
#include <utility>
#include <sstream>
#include <iomanip>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
#define inf 0x3f3f3f3f
#define rep(i,l,r) for(int i=l;i<=r;i++)
#define lep(i,l,r) for(int i=l;i>=r;i--)
#define ms(arr) memset(arr,0,sizeof(arr))
//priority_queue<int,vector<int> ,greater<int> >q;
const int maxn = (int)1e5 + 5;
const ll mod = 1e9+7;
int dp[5][33000];
int main() 
{
    #ifndef ONLINE_JUDGE
    //freopen("in.txt", "r", stdin);
    #endif
    //freopen("out.txt", "w", stdout);
    ios::sync_with_stdio(0),cin.tie(0);
    int n;
    while(scanf("%d",&n)!=EOF) {
    	ms(dp);
    	dp[1][0] = 1;
    	dp[2][0] = 1; dp[2][1] = 1;
    	dp[3][0] = 1; dp[3][1] = 1; dp[3][2] = 2;
    	for(int i=1;i<=3;i++) {
    		for(int j=i;j<=n;j++) {
    			dp[i][j] = dp[i-1][j] + dp[i][j-i];
    		}
    	}
   		printf("%d\n",dp[3][n]);
    }
    return 0;
}

方法二:

由于此题与完全背包问题类似,所以我们还可以将其优化为一维的dp数组

用 dp[i] 代表组成容量为 i 的方案数

dp[j] = dp[j] + dp[j-i];

代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <set>
#include <utility>
#include <sstream>
#include <iomanip>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
#define inf 0x3f3f3f3f
#define rep(i,l,r) for(int i=l;i<=r;i++)
#define lep(i,l,r) for(int i=l;i>=r;i--)
#define ms(arr) memset(arr,0,sizeof(arr))
//priority_queue<int,vector<int> ,greater<int> >q;
const int maxn = (int)1e5 + 5;
const ll mod = 1e9+7;
int dp[33000];
int main() 
{
    #ifndef ONLINE_JUDGE
    //freopen("in.txt", "r", stdin);
    #endif
    //freopen("out.txt", "w", stdout);
    ios::sync_with_stdio(0),cin.tie(0);
    int n;
    while(scanf("%d",&n)!=EOF) {
    	ms(dp);
    	dp[0] = 1;
    	for(int i=1;i<=3;i++) {
    		for(int j=i;j<=n;j++) {
    			dp[j] = dp[j] + dp[j-i];
    		}
    	}
    	printf("%d\n",dp[n]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值