Evolution Game

题目描述

In the fantasy world of ICPC there are magical beasts. As they grow, these beasts can change form, and every time they do they become more powerful. A beast cannot change form completely arbitrarily though. In each form a beast has n eyes and k horns, and these affect the changes it can make.  
 
A beast can only change to a form with more horns than it currently has. 
A beast can only change to a form that has a difference of at most w eyes. So, if the beast currently has n eyes it can change to a form with eyes in range [n - w, n + w]. 
  
A beast has one form for every number of eyes between 1 and N, and these forms will also have an associated number of horns. A beast can be born in any form. The question is, how powerful can one of these beasts become? In other words, how many times can a beast change form before it runs out of possibilities? 

输入

The first line contains two integers, N and w, that indicate, respectively, the maximum eye number, and the maximum eye difference allowed in a change (1 ≤ N ≤ 5000; 0 ≤ w ≤ N).  
The next line contains N integers which represent the number of horns in each form. I.e. the ith number, h(i), is the number of horns the form with i eyes has (1 ≤ h(i) ≤ 1 000 000). 

输出

For each test case, display one line containing the maximum possible number of changes. 

样例输入

复制样例数据

5 5
5 3 2 1 4

样例输出

4

提示

Start with 1 horn and 4 eyes, and it can change 4 times: (1 horn 4 eyes) -> (2 horns 3 eyes) -> (3 horns 2 eyes) -> (4 horns 5 eyes) -> (5 horns 1 eye). 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#include<algorithm>
using namespace std;
struct Beast{
    int horn,eye,len=0;//horn为角数,eye为眼数,len为从该点做起点改变的最大的次数
}bea[5050];
bool cmp(Beast a,Beast b)
{
    return a.horn<b.horn;//按horn从小到大排序
}
bool cmpp(Beast a,Beast b)
{
    return a.len>b.len;按len从大到小排序
}
int main()
{
    int n,w;
    scanf("%d%d",&n,&w);
    for(int i=0;i<n;i++){
        scanf("%d",&bea[i]);
        bea[i].eye=i+1;
    }
    sort(bea,bea+n,cmp);//按horn从小到大排序
    for(int i=n-1;i>=0;i--){//从后往前遍历,用len标记从该点i做起点改变的最大的次数
        int l=-1;
        for(int j=i+1;j<n;j++){//寻找i后面最大的改变次数
            if(bea[j].horn!=bea[i].horn){
                int ph=abs(bea[i].eye-bea[j].eye);
                if(ph<=w&&bea[j].len>l){
                    l=bea[j].len;//一直更新l,使l为后面最大的改变次数
                }
            }
        }
        if(l>=0)
            bea[i].len=l+1;只要l不为0,就证明找到了,然后给当前i的len加1
    }
    sort(bea,bea+n,cmpp);
    cout<<bea[0].len<<endl;排序输出最大的改变次数
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值