hdu 6400 Parentheses Matrix

Problem Description

A parentheses matrix is a matrix where every element is either '(' or ')'. We define the goodness of a parentheses matrix as the number of balanced rows (from left to right) and columns (from up to down). Note that:

- an empty sequence is balanced;
- if A is balanced, then (A) is also balanced;
- if A and B are balanced, then AB is also balanced.

For example, the following parentheses matrix is a 2×4 matrix with goodness 3, because the second row, the second column and the fourth column are balanced:

)()(
()()

Now, give you the width and the height of the matrix, please construct a parentheses matrix with maximum goodness.

Input

The first line of input is a single integer T (1≤T≤50), the number of test cases.

Each test case is a single line of two integers h,w (1≤h,w≤200), the height and the width of the matrix, respectively.

Output

For each test case, display h lines, denoting the parentheses matrix you construct. Each line should contain exactly w characters, and each character should be either '(' or ')'. If multiple solutions exist, you may print any of them.

Sample Input

3

1 1

2 2

2 3

Sample Output

(

()

)(

(((

)))

#define _CRT_SECURE_NO_WARNINGS
#include <stdio.h>
using namespace std;
const int INF = 0x3f3f3f3f;
const int MAX = 205;
typedef long long LL;

int main(void) {
	int t , n , m , i , j;
	scanf("%d" , &t);
	while (t--) {
		scanf("%d%d" , &n , &m);
		if (( n & 1 ) && ( m & 1 )) {
			for (i = 1; i <= n; i++) {
				for (j = 1; j <= m; j++) {
					printf("(");
				}
				printf("\n");
			}
		} else if (n & 1) {
			for (i = 1; i <= n; i++) {
				for (j = 1; j <= m; j++) {
					if (j & 1) printf("(");
					else printf(")");
				}
				printf("\n");
			}
		} else if (m & 1) {
			for (i = 1; i <= n; i++) {
				for (j = 1; j <= m; j++) {
					if (i & 1) printf("(");
					else printf(")");
				}
				printf("\n");
			}
		} else {
			if (n >= m) {
				for (i = 1; i <= n; i++) {
					for (j = 1; j <= m; j++) {
						if (i == 1 && ( m / 2 - 1 ) > 2) {
							printf("(");
							continue;
						}
						if (i == n && ( m / 2 - 1 ) > 2) {
							printf(")");
							continue;
						}
						if (j == 1) {
							printf("(");
							continue;
						}
						if (j == m) {
							printf(")");
							continue;
						}
						if (( i + j ) & 1) {
							printf(")");
						} else {
							printf("(");
						}
					}
					printf("\n");
				}
			} else {
				for (i = 1; i <= n; i++) {
					for (j = 1; j <= m; j++) {
						if (j == 1 && ( n / 2 - 1 ) > 2) {
							printf("(");
							continue;
						}
						if (j == m && ( n / 2 - 1 ) > 2) {
							printf(")");
							continue;
						}
						if (i == 1) {
							printf("(");
							continue;
						}
						if (i == n) {
							printf(")");
							continue;
						}
						if (( i + j ) & 1) {
							printf(")");
						} else {
							printf("(");
						}
					}
					printf("\n");
				}
			}
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值