HDU-1050-Moving Tables



Moving Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19566    Accepted Submission(s): 6686


Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
 

Output
The output should contain the minimum time in minutes to complete the moving, one per line.
 

Sample Input
  
  
3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50
 

Sample Output
  
  
10 20 30
 

Source





建立一个数组用在记录各个最小段(两间房间才能合成为一段,一个点不用移动不能算段)重复的次数;
再找到最大重复的次数;
把最大重复的次数乘以十就是需要求解的总用时长。 





Scoder:
#define MAX 210

#include<iostream>
#include<algorithm>

using namespace std;

int a[MAX];

int f(int n)
{
	if (n % 2 == 0) return n / 2;                    //返回偶数一半
	else return (n + 1) / 2;         //奇数加一成偶数,返回偶数一半
}

int main()
{
	int m, n, x, i, j, t, maxm, T, g;

	cin >> T;                    //输入测试组数

	for(g = 0; g < T; g++)
	{
	    cin >> x;                //that represents the number of tables to move

        for(i = 0; i < MAX; i++) a[i] = 0; //清空各段位为0

	    for(i = 0; i < x; i++)
	    {
	        cin >> m >> n;
	        if(m > n)
	        {
	            t = m; m = n; n = t;   //保持每组小数在前,大数在后
	        }
	        for(j = f(m); j <= f(n); j++) a[j]++; //本段最小段房间(各含两间)每段各加一
	    }

	    maxm = 0;

        for(i = 0; i <= MAX; i++)          //最多200组,全段比较
        {
            if(a[i] > maxm) maxm = a[i];   //找到最大重复的地段
	    }

	    cout << 10 * maxm << endl;         //输出重复乘十,即为所求
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值