HDU-1018-To The Max

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8364    Accepted Submission(s): 4061


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
  
  
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 

Sample Output
  
  
15
 

Source

Greater New York 2001






最大子段和的改编问题,把一维改变为了二维,三层循环就搞定了(划分记录每一个新的子矩阵)。



段错误(核心已转储)

基本上就是越界或者非法访问(我把程序写在了没有挂载权限的硬盘里了)。

主要发生在Linux、ubuntu上面







S:

#define INF 9999         //应该不会爆吧
#include<cstdio>
#include<cstring>
#include<stdlib.h>

using namespace std;

int n, m;
int s[110];                                 //最大不超过100
int d[110][110];

int main()
{
    int i, j, k, t;
    while(scanf("%d", &n) != EOF)
    {
        for(i = 1; i <= n; i++)
            for(j = 1; j <= n; j++)
                  scanf("%d", &d[i][j]);
        m = -INF;

        for(i = 1; i <= n; i++)            //DP,三层循环
        {
            memset(s, 0, sizeof(s));   //清空S(记录子矩阵值用),为“0”
            for(k = 1; k <= n; k++) s[k] = 0;
            for(j = i; j <= n; j++)         //把行值i,传递给j
            {
                t = 0;                            //清“0”,开始记录新的子矩阵
                for(k = 1; k <= n; k++)
                {
                    s[k] += d[j][k];
                    if (t <= 0) t = s[k];
                    else t += s[k];
                    if (t > m) m = t;
                }
            }
        }
        printf("%d\n",m);                 //输出
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值