H电-Prolem Archive-1075-What Are You Talking About

What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 14401    Accepted Submission(s): 4634


Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 

Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 

Output
In this problem, you have to output the translation of the history book.
 

Sample Input
  
  
START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
 

Sample Output
  
  
hello, i'm from mars. i like earth!
Hint
Huge input, scanf is recommended.
 

Author

Ignatius.L






S:

#include<iostream>
#include<string>
using namespace std;
int i;
struct dictree
{
    dictree *child[26];
    char engWord[11];
    dictree()//初始化非常的有必要
    {
        for(i=0;i<26;i++)
            child[i] = NULL;
        engWord[0]='\0';
    }
};
dictree root;
void insert(char eng[],char mar[])//构建字典树
{
    dictree *now = &root;
    char *tmp = mar;
    while(*tmp)
    {
        if(now->child[*tmp-'a']==NULL)
            now->child[*tmp-'a'] = new dictree;
        now = now->child[*tmp-'a'];
        tmp++;
    }
    strcpy(now->engWord,eng);    
}
 
char *find(char ch[])//查找单词
{
    dictree *p = &root;
    int k=0;
    while(1)
    {
        if(ch[k]=='\0' || p->child[ch[k]-'a']==NULL)
            break;
        p = p->child[ch[k]-'a'];
        k++;
    }
    if(ch[k]=='\0' && strcmp(p->engWord,"")!=0)
        return p->engWord;
    return NULL;
}
 
int main()
{
    char a[11],b[11];
    scanf("%s",a);//"START"
    while(scanf("%s",a) && strcmp(a,"END")!=0 )
    {
        scanf("%s",b);
        insert(a,b);
    }
    scanf("%s",a);//"START"
    getchar();//吃回车
    char tmp[3002];
    while(1)
    {
        gets(tmp);//用这个比getline()强
        if(strcmp(tmp,"END") == 0 )
            break;
        int i,len,k=0;
        len = strlen(tmp);
        tmp[len]=' ';//多加一个' ',输出的时候注意
        tmp[++len]='\0';
        char tp[3002];
        for(i=0;i<len;i++)
        {
            if(!(tmp[i]>='a' && tmp[i]<='z'))//非小写字母
            {
                tp[k]='\0';
                char *temp = find(tp);//查找是否有对应的engWord
                if(temp)//存在这个单词
                    printf("%s",temp);
                else                                                    
                    printf("%s",tp);//可以用cout<<tp;//不可以用puts(tp);用puts有换行
                k=0;
                if(i!=len-1)//最后有一个' '是多余的
                    cout<<tmp[i];//输出非小写字母字符
            }
            else //小写字母
                tp[k++]=tmp[i];
        }
        cout<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值