1001. A+B Format (20)

题目:

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991

注意:
1、输出的时候,当某三位的值小于100时别忘了填0,C++中用setfill和setw来控制
2、在网上找到了一个超简洁的版本,顿时扶墙。。。

#include <iostream>
#include <iomanip>
using namespace std;

void output(int x)
{
	if(x>=1000)
		{
			output(x/1000);
			cout<<','<<setfill('0')<<setw(3)<<(x%1000);
		}
	else cout<<x;
}

int main()
{
	int a,b;
	cin>>a>>b;
	int sum=a+b;
	if(sum<0)
	{
		sum=-sum;cout<<'-';
	}
	output(sum);		
	return 0;
}

网上找到的超简洁版本:
#include<stdio.h>
int main()
{
	int a,b;
	int sum;
	while(scanf("%d%d\n",&a,&b) != EOF)
	{
		sum = a+b;
		if(sum < 0)
		{
			printf("-");
			sum = -sum;
		}
		if(sum>=1000000)
			printf("%d,%03d,%03d\n",sum/1000000, (sum/1000)%1000, sum%1000);
		else if(sum >= 1000)
			printf("%d,%03d\n",sum/1000,sum%1000);
		else
			printf("%d\n", sum);
	}
	return 0;
}

这是PAT(A)的第一个题目,虽然看上去很简单,但是需要仔细思考和斟酌的细节还是需要不断去考虑,刷题的路现在才刚刚开始,必须通过不断的练习和锻炼才能逐渐提高自己的思维严谨性。


凡心所向,素履所往;生如逆旅,一苇以航!






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值