1046. Shortest Distance (20)

题目:

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
注意:
1、把这个环里面从一个点到另一个点的两个方向的距离都算出来,取两个距离的最小就可以了。
2、注意所给的数组里面的每一个值指的是从当前点到下一点的距离,在计算时把每个点的累加和算出来更容易计算,不必每次都求和。

代码:
//1046
#include<iostream>
#include<vector>
using namespace std;

int main()
{
	int n;
	scanf("%d",&n);
	vector<int>dis;
	dis.assign(n+1,0);
	for(int i=1;i<=n;++i)
	{
		int t;
		scanf("%d",&t);
		dis[i]=t+dis[i-1];
	}
	int m;
	scanf("%d",&m);
	for(int i=0;i<m;++i)
	{
		int a,b;
		scanf("%d%d",&a,&b);
		//dis[i] is the distance between the i-th and the (i+1)-st exits
		--a; --b;
		if(a>b)
		{
			int k;
			k=a; a=b; b=k;
		}
		int min=dis[dis.size()-1]-dis[b]+dis[a];
		if(dis[b]-dis[a]<min)
			min=dis[b]-dis[a];
		printf("%d\n",min);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值