HDU 2333 && POJ 3497 && UVA 12124 Assemble(二分最大化最小值)

28 篇文章 0 订阅
20 篇文章 0 订阅
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3462 Accepted: 1102

Description

Recently your team noticed that the computer you use to practice for programming contests is not good enough anymore. Therefore, you decide to buy a new computer.

To make the ideal computer for your needs, you decide to buy separate components and assemble the computer yourself. You need to buy exactly one of each type of component.

The problem is which components to buy. As you all know, the quality of a computer is equal to the quality of its weakest component. Therefore, you want to maximize the quality of the component with the lowest quality, while not exceeding your budget.

Input

On the first line one positive number: the number of testcases, at most 100. After that per testcase:

  • One line with two integers: 1 ≤ n ≤ 1 000 , the number of available components and 1 ≤b ≤ 1 000 000 000 , your budget.

  • n lines in the following format: “type name price quality”, wheretype is a string with the type of the component, name is a string with the unique name of the component,price is an integer (0 ≤ price ≤ 1 000 000 ) which represents the price of the component andquality is an integer (0 ≤ quality ≤ 1 000 000 000 ) which represents the quality of the component (higher is better). The strings contain only letters, digits and underscores and have a maximal length of 20 characters.

Output

Per testcase:

  • One line with one integer: the maximal possible quality.

Sample Input

1
18 800
processor 3500_MHz 66 5
processor 4200_MHz 103 7
processor 5000_MHz 156 9
processor 6000_MHz 219 12
memory 1_GB 35 3
memory 2_GB 88 6
memory 4_GB 170 12
mainbord all_onboard 52 10
harddisk 250_GB 54 10
harddisk 500_FB 99 12
casing midi 36 10
monitor 17_inch 157 5
monitor 19_inch 175 7
monitor 20_inch 210 9
monitor 22_inch 293 12
mouse cordless_optical 18 12
mouse microsoft 30 9
keyboard office 4 10

Sample Output

9

Source

Northwestern Europe 2007

题目大意:

    组装一台电脑,给出各个部分的价钱和质量,求用一定的钱组装电脑,使最小的质量最大(每部分必须买一个)
解题思路:
    明显的最大化最小值,自然想到用二分写,二分质量,每次用O(n)的复杂度把所有硬件扫描一遍,检查这个质量是否满足要求。这里硬件名称是字符串,如果直接存字符串的话会超时,应该为每个字符串设置一个id,用这个id代替字符串就回快很多。
    关于设置id的方法参考大神方法: http://blog.csdn.net/blzorro/article/details/9960893?utm_source=tuicool&utm_medium=referral
附AC代码
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <map>
#include <string>
using namespace std;

const int max_len=20+5;
const int maxn=1000+5;
int n,m;
char temp[max_len];
map<string, int>  id;
int cnt;

struct hardware
{
    int quality,money,id;
    hardware(int i=0,int q=0,int m=0):id(i),quality(q),money(m){}
    bool operator<(const hardware &other)const
    {
        if(id==other.id)
            return money<other.money;
        else return id<other.id;
    }
}save[maxn];

bool judge(int x)//判断当前质量是否满足条件
{
    int sum=0;
    bool flag=false;//用来记录每个硬件是否有满足条件的
    if(save[0].quality>=x)
    {
        flag=true;
        sum+=save[0].money;
    }
    for(int i=1;i<n;++i)
    {
        if(save[i].id!=save[i-1].id)
        {
            if(!flag)
                return false;
            if(save[i].quality>=x)
            {
                flag=true;
                sum+=save[i].money;
            }
            else flag=false;
        }
        else
        {
            if(flag)
                continue;
            else if(save[i].quality>=x)
            {
                flag=true;
                sum+=save[i].money;
            }
        }
    }
    if(sum<=m&&flag)
        return true;
    else return false;
}

int find_id(char *s)//为每个硬件设置id
{
    if(!id[s])
        id[s]=cnt++;
    return id[s];
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        cnt=1;//初始化
        id.clear();
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;++i)
        {
            scanf("%s",temp);
            save[i].id=find_id(temp);
            scanf("%s%d%d",temp,&save[i].money,&save[i].quality);
        }
        sort(save,save+n);//排序方便判断
        int l=0,r=1000000000+1;
        while(r-l>1)//二分
        {
            int mid=(l+r)>>1;
            if(judge(mid))
                l=mid;
            else r=mid;
        }
        printf("%d\n",l);
    }
    
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值