POJ 3420 Quad Tiling(轮廓线DP+矩阵快速幂)

34 篇文章 1 订阅
21 篇文章 0 订阅
Quad Tiling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4076 Accepted: 1856

Description

Tired of the Tri Tiling game finally, Michael turns to a more challengeable game, Quad Tiling:

In how many ways can you tile a 4 × N (1 ≤ N ≤ 109) rectangle with 2 × 1 dominoes? For the answer would be very big, output the answer modulo M (0 < M ≤ 105).

Input

Input consists of several test cases followed by a line containing double 0. Each test case consists of two integers, N and M, respectively.

Output

For each test case, output the answer modules M.

Sample Input

1 10000
3 10000
5 10000
0 0

Sample Output

1
11
95

Source


题目大意:

    有一个4*N的二维容器,放入1*2的砖块,求总方案数。


解题思路:

    明显轮廓线dp,由于有宽度为4,所以轮廓有1<<4=16种状态,不过我们手动模拟一下就可以发现只会出现其中的6种状态,状态转移也非常简单,直接手动构造矩阵,矩阵快速幂求得结果即可。(详细状态,及转移方程见下图,当时随便打的草稿,写的很随意请不要在意)


AC代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
#include <cmath>
using namespace std;
#define vec vector<int>
#define mat vector<vec>
#define LL long long

int N,M;

//计算A*B
mat mul(mat &A,mat &B)
{
    mat C(A.size(),vec(B[0].size()));
        for(int i=0;i<A.size();++i)
            for(int k=0;k<B.size();++k)
                if(A[i][k]!=0)//如果A[i][j]==0则一定为0
                    for(int j=0;j<B[0].size();++j)
                        C[i][j]=(C[i][j]+A[i][k]*B[k][j])%M;
    return C;
}

//计算A^B
mat pow(mat A,LL n)
{
    mat B(A.size(),vec(A.size()));
    for(int i=0;i<A.size();++i)
        B[i][i]=1;
    while(n>0)
    {
        if(n&1)
            B=mul(B,A);
        A=mul(A,A);
        n>>=1;
    }
    return B;
}

int main()
{
    while(~scanf("%d%d",&N,&M)&&(N||M))
    {
        mat b(6,vec(6));//状态转移方程矩阵
        b[0][0]=1; b[0][1]=1; b[0][2]=1; b[0][3]=1; b[0][4]=1; b[0][5]=0;
        b[1][0]=1; b[1][1]=0; b[1][2]=1; b[1][3]=0; b[1][4]=0; b[1][5]=0;
        b[2][0]=1; b[2][1]=1; b[2][2]=0; b[2][3]=0; b[2][4]=0; b[2][5]=0;
        b[3][0]=1; b[3][1]=0; b[3][2]=0; b[3][3]=0; b[3][4]=0; b[3][5]=1;
        b[4][0]=1; b[4][1]=0; b[4][2]=0; b[4][3]=0; b[4][4]=0; b[4][5]=0;
        b[5][0]=0; b[5][1]=0; b[5][2]=0; b[5][3]=1; b[5][4]=0; b[5][5]=0;
        printf("%d\n",pow(b,N)[0][0]);
    }
    
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
以下是Java解决POJ3233—矩阵序列问题的代码和解释: ```java import java.util.Scanner; public class Main { static int n, k, m; static int[][] A, E; public static void main(String[] args) { Scanner sc = new Scanner(System.in); n = sc.nextInt(); k = sc.nextInt(); m = sc.nextInt(); A = new int[n][n]; E = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { A[i][j] = sc.nextInt() % m; E[i][j] = (i == j) ? 1 : 0; } } int[][] res = matrixPow(A, k); int[][] ans = matrixAdd(res, E); printMatrix(ans); } // 矩阵乘法 public static int[][] matrixMul(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { for (int k = 0; k < n; k++) { c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % m; } } } return c; } // 矩阵快速 public static int[][] matrixPow(int[][] a, int b) { int[][] res = E; while (b > 0) { if ((b & 1) == 1) { res = matrixMul(res, a); } a = matrixMul(a, a); b >>= 1; } return res; } // 矩阵加法 public static int[][] matrixAdd(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { c[i][j] = (a[i][j] + b[i][j]) % m; } } return c; } // 输出矩阵 public static void printMatrix(int[][] a) { for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { System.out.print(a[i][j] + " "); } System.out.println(); } } } ``` 解释: 1. 首先读入输入的n、k、m和矩阵A,同时初始化单位矩阵E。 2. 然后调用matrixPow函数求出A的k次矩阵res。 3. 最后将res和E相加得到结果ans,并输出。 4. matrixMul函数实现矩阵乘法,matrixPow函数实现矩阵快速,matrixAdd函数实现矩阵加法,printMatrix函数实现输出矩阵

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值