HDU 5900 QSC and Master(区间DP)

34 篇文章 1 订阅
28 篇文章 0 订阅

QSC and Master

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 312    Accepted Submission(s): 103


Problem Description
Every school has some legends, Northeastern University is the same.

Enter from the north gate of Northeastern University,You are facing the main building of Northeastern University.Ninety-nine percent of the students have not been there,It is said that there is a monster in it.

QSCI am a curious NEU_ACMer,This is the story he told us.

It’s a certain period,QSCI am in a dark night, secretly sneaked into the East Building,hope to see the master.After a serious search,He finally saw the little master in a dark corner. The master said:

“You and I, we're interfacing.please solve my little puzzle!

There are N pairs of numbers,Each pair consists of a key and a value,Now you need to move out some of the pairs to get the score.You can move out two continuous pairs,if and only if their keys are non coprime(their gcd is not one).The final score you get is the sum of all pair’s value which be moved out. May I ask how many points you can get the most?

The answer you give is directly related to your final exam results~The young man~”

QSC is very sad when he told the story,He failed his linear algebra that year because he didn't work out the puzzle.

Could you solve this puzzle?

(Data range:1<=N<=300
1<=Ai.key<=1,000,000,000
0<Ai.value<=1,000,000,000)
 

Input
First line contains a integer T,means there are T(1≤T≤10) test case。

  Each test case start with one integer N . Next line contains N integers,means Ai.key.Next line contains N integers,means Ai.value.
 

Output
For each test case,output the max score you could get in a line.
 

Sample Input
  
  
3 3 1 2 3 1 1 1 3 1 2 4 1 1 1 4 1 3 4 3 1 1 1 1
 

Sample Output
  
  
0 2 0
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5901  5899  5898  5897  5896

题目大意:
    输入N个pair<int,int>若相邻两个点first的gcd!=1则可以消去,并得到这两个pair的second之和的分数。求所得分数最大值。

解题思路:
    好久没写区间dp了,连区间dp最基本的先枚举长度,再枚举起点,再划分区间都忘了,比赛时一眼就看出了是dp,不过一直没想到区间dp。。。真是太菜了。
    比赛后仔细想了一下,和区间dp的经典题目括号匹配是差不多的。有一个比较大的区别就是这题要中间全部消掉才能继续消两边。所以我们可以进行两次区间,第一次先处理出任意一个区间是否可以消完,第二次计算任意一个区间可以获得的最大分数。状态转移和常见的区间dp没有什么区别,详情请见代码。

AC代码:
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <cmath>
#include <map>
#include <cstdlib>
#include <string>
#include <set>
using namespace std;
#define INF 0x3f3f3f3f
#define LL long long
#define ULL unsigned long long
#define fi first
#define se second
#define mem(a,b) memset((a),(b),sizeof(a))

const int maxn=300+3;
LL val[maxn],dp[maxn][maxn],sum[maxn];
bool can[maxn][maxn];
int N,key[maxn];

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        mem(can,0);
        mem(dp,0);
        scanf("%d",&N);
        for(int i=1;i<=N;++i)
            scanf("%d",&key[i]);
        for(int i=1;i<=N;++i)
        {
            scanf("%lld",&val[i]);
            sum[i]=sum[i-1]+val[i];//计算前缀和,方便后来求区间val之和
        }
        //第一次区间dp,标记[i,j]能否全部删去
        for(int i=1;i<N;++i)
            can[i][i+1]=(__gcd(key[i],key[i+1])!=1);
        for(int i=3;i<N;++i)//长度
            for(int l=1;l+i<=N;++l)//左端点
            {
                int r=l+i;
                if(can[l+1][r-1]&&__gcd(key[l],key[r])!=1)
                    can[l][r]=true;
                else
                {
                    for(int k=l;k<r;++k)
                        if(can[l][k]&&can[k+1][r])
                        {
                            can[l][r]=true;
                            break;
                        }
                }
            }
        //第二次区间dp,计算[i,j]的最大得分
        for(int i=1;i<N;++i)//长度
            for(int l=1;l+i<=N;++l)
            {
                int r=l+i;
                if(can[l][r])
                    dp[l][r]=max(dp[l][r],sum[r]-sum[l-1]);
                for(int k=l;k<r;++k)
                    dp[l][r]=max(dp[l][r],dp[l][k]+dp[k+1][r]);
            }
        printf("%lld\n",dp[1][N]);
    }
    
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值