1005 Spell It Right (20分)(一个字短!)

1005 Spell It Right (20分)

题目

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.
Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤10​100​​).
Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345

Sample Output:
one five

题意

对各位数字求和,并按照格式输出

分析

输入到string中,逐位求和

代码

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
string nums[10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
char num[101];
int printNum[101];
int sum;
int main(){
 	scanf("%s",num);
 	int len=strlen(num);
	sum=0;
 	for(int i=0;i<len;i++){
  		sum+=num[i]-'0';
 	}
	int size=0;
 	if(sum==0){
  		size=1;
 	}
 	while(sum!=0){
  		printNum[size]=sum%10;
  		sum/=10;
  		size++;
 	}
 	for(int i=size-1;i>=0;i--){
  		printf("%s",nums[printNum[i]].c_str());
  		if(i!=0)
  		printf(" ");
 	}
 	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值