string处理储存数字+string输入+输出 1005 Spell It Right (20分) 1006 Sign In and Sign Out (25分)

这篇博客介绍了两道编程题目,1005 Spell It Right 要求计算非负整数的各位数字之和并用英文单词输出,而1006 Sign In and Sign Out 则需要找出每天解锁和锁定计算机房门的人员ID。对于1005题,可以使用字符串存储数字,逐位求和并转换为英文输出。1006题中,要处理签到和签退记录,确保正确处理时间顺序,找出首签到和末签退的人。
摘要由CSDN通过智能技术生成

1005 Spell It Right (20分)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤10^100).

Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

解题
用字符串类型保存数字,求各个位数的和,转化为字符类型,按顺序挨个输出即可;

#include<iostream>
#include<cstring>
using namespace std;

string Num;
void input()
{
   
	cin>>Num;
	//计算位数
	int s=0;
	for(int i=0;i<Num.size();i++){
   
		s+=Num[i]-'0';
	}
	string R=to_string(s);
	for(int i=0;i<R.size();i++)
	{
   
		switch(R[i]){
   
		
			case '1':
				cout<<"one";
				break;
			case'2':
				cout<<"two";
				break;
			
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值