PAT(甲级) 1005 Spell It Right (20分)

题目来源:PAT(甲级) 1005 Spell It Right (20分)
题目描述:
Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10^​100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

题目翻译:
将给出一串数字的每一位进行求和,得到结果将和的每一位用英文进行输出,并注意输出的格式。
注意事项:

  • 当数字串和为0时,按照自己的方法判断是否需要特殊考虑
  • 在while(sum!=0)时就会将和为0的情况忽略掉
#include<iostream>
#include<string>
#include<vector>
using namespace std;

string english[10] = { "zero","one","two","three","four","five","six","seven","eight","nine" };
int main()
{
	string N;
	cin >> N;
	int sum = 0;
	vector<int> V; //用来存储求和后的每一位数字
	for (int i = 0;i < N.length();i++)
		sum += N[i]-'0';
	if (sum == 0)
		V.push_back(0);
	else
	{
		while (sum != 0)
		{
			int temp = 0;
			temp = sum % 10;
			sum = sum / 10;
			V.push_back(temp);
		}
	}
	for (int i = V.size()-1;i >= 0;i--) //逆序插入 逆序输出
	{
		cout << english[V[i]];
		if (i != 0) cout << " ";
	}
	cout << endl;
	return 0;
}

2020/02/02 因为喜欢上一个人,对未来充满向往!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值