PAT甲级 1001 A+B Format (20分)

PAT甲级 1001 A+B Format (20分)

  1. 题目描述
    Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
    Input Specification:
    Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.
    Output Specification:
    For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
    Sample Input:
-1000000 9

Sample Output:

-999,991

2.解题思路

题目大意:对于两个位于 1 0 − 6 10^{-6} 106 1 0 6 10^{6} 106之间的整数a和b,以一种标准的形式输出其相加之后的结果,即:
若结果位数小于4位,则正常输出;
若结果位数大于四位,从低位到高位每三位以逗号分隔。
思路:
首先要判断a+b的结果(sum)的正负,若为负,则首先输出一个负号后再将sum转换为正数,便于求每个数位上的值;
其次,对sum求余得到每个数位上的值,并存储到结果数组中,此时数组中存储的是转换为正数之后的结果的倒序;
最后,对数组进行从高到底进行输出,若数组下标对3取余等于0,则输出一个‘,’进行分隔。
3. 注意点
此题容易漏写结果为0的情况,应该加上一条sum为0时的判断。

在这里插入图片描述

  • AC代码
#include<iostream>
using namespace std;
int main()
{
 int a,b,sum=0;
 int result[10];
 scanf("%d %d",&a,&b);
 sum=a+b;
 if(sum==0)
 {
  printf("0");
  return 0;
  } 
 if(sum<0)
 {
  printf("%c",'-');
  sum=-sum;
 }
 int i=0;
 while(sum>0)
 {
  result[i++]=sum%10;
  sum=sum/10;
 }
 for(int j=i-1;j>=0;j--)
 {
  printf("%d",result[j]);
  if(j%3==0&&j!=0)
  {
   printf("%c",',');
  }
 }
 return 0;
 
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值