PAT 甲级1005 Spell It Right (20分)

PAT 甲级1005 Spell It Right

  1. 题目详情
    Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.
    Input Specification:
    Each input file contains one test case. Each case occupies one line which contains an N (≤ 1 0 100 10^{100} 10100​​).
    Output Specification:
    For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.
    Sample Input:
12345

Sample Output:

one five
  1. 题目大意
    给定一个小于或等于 1 0 100 10^{100} 10100的正整数N,要求计算出其各位的和,并以英文的形式输出该结果。
  2. 解题思路
    题目比较简单,就是先对N求出各位上的数字进行相加,然后再对相加结果求出各位上的数存储在数组中,最终对该数组从末位往前比对其英文形式输出。
    注意点:
    数字N的大小是小于等于 1 0 100 10^{100} 10100的,因此int 类型或者是long long类型对其存储有可能会溢出,应该考虑使用字符数组存储,再对每位字符减去字符‘0’转化为整数计算其和。
    在这里插入图片描述
    AC代码
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
int main()
{
 char N[101];
 int count=0;
 int result[110];
 int sum=0;
 string en[10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
 scanf("%s",N);
 for(int i=0;i<strlen(N);i++)
 {
  sum+=N[i]-'0';
 }
 if(sum==0)
 {
  printf("zero");
  } 
 while(sum)
 {
  result[count++]=sum%10;
  sum/=10;
 }
 for(int i=count-1;i>=0;i--)
 {
  printf("%s",en[result[i]].c_str());
  if(i>0)
  {
   printf(" ");
  }
 }
 return 0;
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值