PAT甲级 1011 World Cup Betting (20分)

1011 World Cup Betting (20分)

1.题目描述

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.
Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.
For example, 3 games’ odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).
Input Specification:
Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.
Output Specification:
For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.
Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31
  1. 题目大意
    对于三场比赛,每场比赛可以选择W(赢),T(平局),L(输)。给出每场比赛选择W、T或L的投注赔率,获胜者的总赔率是三场比赛各投注赔率的乘积乘以65%。
    最大利润由(4.1×3.1×2.5×65%−1)×2=39.31该式算出。
  2. 解题思路
    观察最大利润的算式,可以知道,只需在每场比赛中,找出投注赔率最大的即可。对于输出每场比赛的投注选择,判断当前行的最大值所在列是第几列,如为0,代表"W",则输出"W",依次类推。
    在这里插入图片描述
    AC代码
#include<cstdio>
using namespace std;
int main()
{
 double bet[3][3];
 int g;
 for(int i=0;i<3;i++)
 {
  for(int j=0;j<3;j++)
  {
   scanf("%lf",&bet[i][j]);
  }
 }
 double max=0,sum=1;
 for(int i=0;i<3;i++)
 {
  
  max=bet[i][0];
  g=0;
  for(int j=1;j<3;j++)
  {
   if(bet[i][j]>max)
   {
    max=bet[i][j];
    g=j;
   }
  }
  sum*=max;
  if(g==0)
  {
   printf("W");
  }else if(g==1)
  {
   printf("T");
  }else
  {
   printf("L");
  }
  printf(" ");
 
 }
 printf("%.2lf",(sum*65/100-1)*2);
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值