[PAT A1011]World Cup Betting

[PAT A1011]World Cup Betting

题目描述

1011 World Cup Betting (20 分)With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.
Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.
For example, 3 games’ odds are given as the following:
W T L
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1
To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

输入格式

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

输出格式

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

输入样例

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

输出样例

T T W 39.31

解析

  1. 就是一道简单题,使用的方法是简单模拟
  2. 题目解读:意思是给出三场比赛的赔率,开始输入三行数,每行代表一场比赛,每一行的三个数字分别代表了赢,平和输,然后我们按照公式(第一行大的数x第二行最大的数x第三行最大的数x0.65-1)x2得到最终的结果
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
 double sum = 0, temp;
 char bet[3];   //存放的是赌的胜负
 double odd[3];  //存放的是每一行最大的数
 double w, t, l;
 for (int i = 0; i < 3; i++)
 {
  cin >> w >> t >> l;
  bet[i] = (w > t) ? (t > l ? 'W' : (w > l ? 'W' : 'L')) : (w > l ? 'T' : (t > l ? 'T' : 'L'));    //计算出bet[i]
  odd[i] = max(max(w, l), t);
 }
 sum = (odd[0] * odd[1] * odd[2] * 0.65 - 1) * 2;
 cout << bet[0] << " " << bet[1] << " " << bet[2] << " ";
 printf("%.2f", sum); //注意格式
 return 0;
}
水平有限,如果代码有任何问题或者有不明白的地方,欢迎在留言区评论;也欢迎各位大牛提出宝贵的意见!
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值