PAT (Advanced Level) 1002 A+B for Polynomials

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

  • 水题……还WA了几次
  • 计算两个多项式A+B相加的结果
  •  段错误:1)访问系统数据区,尤其是往系统保护的内存地址写数据最常见就是给一个指针以0地址。2)内存越界(数组越界,变量类型不一致等): 访问到不属于你的内存区域。——感觉和runtime error差不多
  • 读题要仔细啊!!!

 

#include<stdio.h>
#include<string.h>
#define maxn 1005
double ans[maxn];

int main()
{
    int k;
    while(scanf("%d",&k)!=EOF)
    {
        memset(ans,0,sizeof(ans));
        int n,number=0;
        double an;
        for(int i=1;i<=k;i++)
        {
            scanf("%d",&n);
            scanf("%lf",&an);
            ans[n]+=an;
        }
        scanf("%d",&k);
        for(int i=1;i<=k;i++)
        {
            scanf("%d",&n);
            scanf("%lf",&an);
            ans[n]+=an;
        }
        for(int i=0;i<=1000;i++)
            if(ans[i]!=0)
                number++;
        printf("%d",number);
        for(int i=1000;i>=0;i--)
            if(ans[i])
                printf(" %d %.1lf",i,ans[i]);
        printf("\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值