1152 Google Recruitment atoi函数和stoi函数

In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google’s hiring process by visiting this website.

The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921… where the 10 digits in bold are the answer to Google’s question.

Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:
Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:
For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:
20 5
23654987725541023819
Sample Output 1:
49877
Sample Input 2:
10 3
2468024680
Sample Output 2:
404

题干太长了,其实很简单,从给定的数字串中,从头开始k位k位地取,输出取到的第一个素数。

我一看L<=1000,k<=10,这如果用传统的素数判断算法时间,复杂度是O(10^3 * 10 ^5),即O(10)肯定炸了,就没招了,结果写了一摊垃圾。但是为什么网上的题解还是用这个方法过了?

  • int atoi(const char*),返回字符串数组表示的数字,会做范围判断,如果该数字超过了int范围,会输出int的最大值。string需要用s.c_str()返回char*才能用做该函数参数。同理有atol
  • int stoi (const string& str, size_t* idx = 0, int base = 10);返回string对象str表示的数字的十进制值,idx我没搞懂是什么意思,用的时候只要用nullptr代替就行,bas是str中的数制,默认是10,如果不是10,就是将其他进制数的字符串转为10进制int型数输出。同理有stol(返回long int),stoll(返回long long)。
#include <bits/stdc++.h>
using namespace std;

bool isPrime(int n) {
   if (n==0||n==1) return false;
   for (int i=2;i*i<=n;i++)    {
       if (n%i==0) return false;
   }
   return true;
}

int main()  {
   int l,m;
   string s;
   cin>>l>>m;
   cin>>s;
   for (int i=0;i<=l-m;i++) {
       string ts=s.substr(i,m);			//s.substr(a,b)意为返回从s下标为a处的连续b个元素组成的字符串
       int t=stoi(ts);
       if (isPrime(t)) {
           cout<<ts<<endl;
           return 0;
       }
   }
   cout<<404<<endl;
   return 0;
}

主要参考了柳婼大神的博客(其实和她写的几乎一模一样,-_-||),我自己写的和她的一比,真的就是一坨垃圾。

复杂度上面写了,我觉得是O(10^8),但是可能没有特殊样例,让我侥幸过关。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值