1153 Decode Registration Card of PAT (25 分) 复杂结构体排序

一不小心把这个博客重新编辑了,把1153的题解替换成了1154的了,结果整篇博客都没了。。。靠回忆重新补一下吧。

A registration card number of PAT consists of 4 parts:

the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
the 2nd - 4th digits are the test site number, ranged from 101 to 999;
the 5th - 10th digits give the test date, in the form of yymmdd;
finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.
Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤10
​4
​​ ) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.
Output Specification:
For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.
If the result of a query is empty, simply print NA.

Sample Input:
8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999
Sample Output:
Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

限定条件的复杂结构体排序。题目我不翻译了,忘了。

这道题选择数据结构是重点,观察到命令1和命令3虽然看起来不同,但是如果将数字用字符串来存,那么1和3的排序要求就可以统一起来,就能够用一个数据结构来处理。

下面是代码。

  • cout极其极其缓慢,这道题用cout直接超时,即便用了ios::sync_with_stdio(false)优化也超时。以后直接用printf吧

  • pair型变量可以用花括号来构造,就像这样

      pair<string,int> temp={"hello",666};
    
  • for (auto it : elem) 能够直接遍历整个elem对象,例如如果elem是数组a[],it就可以当做a[i].

  • string下的substr方法用于字符串切割,用法是s.substr(a,b),意为返回从s[a]起b个字符的字符串

#include <bits/stdc++.h>                   //第三次修改,将所有的cout改成了printf。
using namespace std;                       //事实证明即便用了ios优化代码,cout也比printf慢得多
struct node{
    string nb;
    int s;
};
bool cmp(const node& a,const node& b)   {
    return (a.s==b.s)?(a.nb<b.nb):(a.s>b.s);
}
int main()  {
    int n,m,op;
    string ts;
    cin>>n>>m;
    vector<node> vn(n);
    for (int i=0;i<n;i++)
        cin>>vn[i].nb>>vn[i].s;
    for (int i=0;i<m;i++)   {
        vector<node> ans;
        int tts=0,cnt=0;
        cin>>op>>ts;
        printf("Case %d: %d %s\n",i+1,op,ts.c_str());
        if (op==1)  {
            for (int j=0;j<n;j++)   {
                if (vn[j].nb[0]==ts[0])
                    ans.push_back(vn[j]);
            }
        }
        else if (op==2) {
            for (int j=0;j<n;j++)   {
                if (vn[j].nb.substr(1,3)==ts)   {
                    cnt++;
                    tts+=vn[j].s;
                }
            }
            if (cnt) printf("%d %d\n",cnt,tts);
        }
        else if (op==3) {
            unordered_map<string,int> ui;
            for (int j=0;j<n;j++)   {
                if (vn[j].nb.substr(4,6)==ts)
                    ui[vn[j].nb.substr(1,3)]++;
            }
            for (auto it:ui)    ans.push_back({it.first,it.second});
        }
        sort(ans.begin(),ans.end(),cmp);
        for (auto it:ans) printf("%s %d\n",it.nb.c_str(),it.s);
        if (((op==1||op==3)&&ans.empty())||(op==2&&cnt==0)) printf("NA\n");
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值