1153 Decode Registration Card of PAT (25 分)

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (104) and M (100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Termwill be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

 

C++:

/*
 @Date    : 2018-12-27 13:13:43
 @Author  : 酸饺子 (changzheng300@foxmail.com)
 @Link    : https://github.com/SourDumplings
 @Version : $Id$
*/

/*
https://pintia.cn/problem-sets/994805342720868352/problems/1071785190929788928
 */

// 如果用int 类型变量读取输入的指令中的考场编号或日期信息时,输出时考场编号和日期分别要输出3位和6位,不够要在高位补0

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
#include <unordered_map>

using namespace std;

const int MAXN = 10005;
int N, M;

struct Student
{
    string cardName;
    char type;
    int site, date, grade;
};

vector<Student> data;
unordered_map<char, vector<int>> types;
unordered_map<int, pair<int, int>> sites;
unordered_map<int, unordered_map<int, int>> dates;
unordered_map<int, vector<pair<int, int>>> datesResults;

void process(const string &cardName, int i)
{
    data[i].type = cardName[0];
    data[i].site = stoi(cardName.substr(1, 3));
    data[i].date = stoi(cardName.substr(4, 6));
    return;
}

bool cmpSitePair(const pair<int, int> &p1, const pair<int, int> &p2)
{
    if (p1.second == p2.second)
        return p1.first < p2.first;
    return p1.second > p2.second;
}

bool cmpGrade(const int i1, const int i2)
{
    if (data[i1].grade == data[i2].grade)
        return data[i1].cardName < data[i2].cardName;
    return data[i1].grade > data[i2].grade;
}

void output1(int seq)
{
    char test;
    cin >> test;
    cout << "Case " << seq << ": 1 "<< test << endl;
    if (types.find(test) == types.end())
    {
        cout << "NA" << endl;
        return;
    }
    for (int i : types[test])
    {
        cout << data[i].cardName << " " << data[i].grade << endl;
    }
    return;
}

void output2(int seq)
{
    int term;
    cin >> term;
    cout << "Case " << seq << ": 2 ";
    printf("%03d\n", term);
    if (sites.find(term) == sites.end())
    {
        cout << "NA" << endl;
        return;
    }
    cout << sites[term].first << " " << sites[term].second << endl;
    return;
}

void output3(int seq)
{
    int term;
    cin >> term;
    cout << "Case " << seq << ": 3 ";
    printf("%06d\n", term);
    if (datesResults.find(term) == datesResults.end())
    {
        cout << "NA" << endl;
        return;
    }
    for (auto &p : datesResults[term])
    {
        cout << p.first << " " << p.second << endl;
    }
    return;
}

int main()
{
    cin >> N >> M;
    data.resize(N);
    for (int i = 0; i != N; ++i)
    {
        cin >> data[i].cardName >> data[i].grade;
        process(data[i].cardName, i);
    }
    for (int i = 0; i != N; ++i)
    {
        types[data[i].type].push_back(i);
        ++sites[data[i].site].first;
        sites[data[i].site].second += data[i].grade;
        ++dates[data[i].date][data[i].site];
    }
    for (auto &eachType : types)
        sort(eachType.second.begin(), eachType.second.end(), cmpGrade);
    for (auto &eachDate : dates)
    {
        for (auto &p : eachDate.second)
            datesResults[eachDate.first].push_back(make_pair(p.first, p.second));
        sort(datesResults[eachDate.first].begin(), datesResults[eachDate.first].end(), cmpSitePair);
    }
    for (int i = 0; i != M; ++i)
    {
        int type;
        cin >> type;
        switch (type)
        {
            case 1: output1(i + 1); break;
            case 2: output2(i + 1); break;
            case 3: output3(i + 1); break;
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值