POJ 1125 Stockbroker Grapevine 【最短路(Floyd算法)】

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

题意:股票经纪人要在一群人中散布一个谣言,而谣言只能在亲密的人中传递,题目给出了人与人之间的关系及传递谣言所用的时间,要求程序给出应以哪个人为起点,可以在最短的时间内让所有的人都得知这个谣言。要注意从a到b传递的时间不一定等于从b到a的时间,如果没有方案能够让每一个人都知道谣言,则输出"disjoint"

数据处理:题目数据的输入第一行为n,代表总人数,当n=0时结束程序,接着n行,第i+1行的第一个是一个整数m,表示第i个人与m个人的关系要好,接着有m对整数,每对的第一个数是j,表示i与j要好,第二个数是从i直接传递谣言到j所用的时间,数据的输出是两个整数,第一个为选点的散布谣言的起点,第二个整数时所有人得知谣言的最短时间。

例如:对于数据1,从3开始传播,到1和2的时间都是2,故程序输出的结果是3 2。

(这次题解写的这么详细是因为我在找别人的题解时只看到了乱糟糟的代码,让我很郁闷,所以我决定今后每次都写得详细一点,当然借鉴他人经验是必不可少的,比如这篇的上述文字就是..传送门

AC代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int inf = 0x3f3f3f3f;
int dis[105][105];
int n;

void init()
{
    for(int i = 0; i < 105; ++i)
        for(int j = 0; j < 105; ++j)
    {
        if(i == j) dis[i][j] = 0;
        else dis[i][j] = inf;
    }
}

int main()
{
    int m;
    int x, y;
    while(scanf("%d",&n) && n)
    {
        init();
        for(int i = 0; i < n; ++i)
        {
            scanf("%d",&m);
            while(m--)
            {
                scanf("%d%d",&x,&y);
                dis[i][x - 1] = y;
            }
        }
        for(int k = 0; k < n; ++k)  //Floyd  注意i、j、k的顺序
            for(int i = 0; i < n; ++i)
                for(int j = 0; j < n; ++j)
                    dis[i][j] = min(dis[i][j], dis[i][k] + dis[k][j]);

        int ans1, ans2 = inf;
        int tem1, tem2;
        for(int i = 0; i < n; ++i)
        {
            tem2 = 0;
            for(int j = 0; j < n; ++j)
                {
                    if(tem2 < dis[i][j])
                    {
                        tem1 = i;
                        tem2 = dis[i][j];
                    }
                }
            if(ans2 > tem2)
            {
                ans1 = tem1;
                ans2 = tem2;
            }
        }

        if(ans2 >= inf) cout << "disjoint" << endl;
        else cout << ans1 + 1 << " " << ans2 << endl;

    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值