POJ 1330 Nearest Common Ancestors 【最近公共祖先】

Description

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:


In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is.

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y.

Write a program that finds the nearest common ancestor of two distinct nodes in a tree.

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3

没啥好写的,存模板用的一道题。

AC代码1(在线算法 DFS + ST):

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int MAX = 10010;
int rmq[2*MAX]; //rmq数组,欧拉序列对应的深度序列
struct ST
{
    int mm[2*MAX];
    int dp[2*MAX][20];//最小值对应的下标
    void init(int n)
    {
        mm[0] = -1;
        for(int i = 1; i <= n; ++i)
        {
            //i&(i-1)
            mm[i] = ((i&(i-1)) == 0) ? mm[i-1]+1 : mm[i-1];
            dp[i][0] = i;
        }
        for(int j = 1; j <= mm[n]; ++j)
            for(int i = 1; i + (1<<j) -1 <= n; ++i)
                dp[i][j] = rmq[dp[i][j-1]] < rmq[dp[i+(1<<(j-1))][j-1]] ? dp[i][j-1] : dp[i+(1<<(j-1))][j-1];
    }
    int query(int a, int b)//查询[a,b]之间最小值的下标
    {
        if(a > b) swap(a, b);
        int k = mm[b-a+1];
        return rmq[dp[a][k]] <= rmq[dp[b-(1<<k)+1][k]] ? dp[a][k] : dp[b-(1<<k)+1][k];
    }
};

//边的结构体定义
struct Edge
{
    int to, next;
};
Edge edge[MAX*2];
int tot, head[MAX];

int F[MAX*2];
int P[MAX];
int cnt;

ST st;
void init()
{
    tot = 0;
    memset(head, -1, sizeof(head));
}
void addedge(int u, int v)
{
    edge[tot].to = v;
    edge[tot].next = head[u];
    head[u] = tot++;
}
void dfs(int u, int pre, int dep)
{
    F[++cnt] = u;
    rmq[cnt] = dep;
    P[u] = cnt;
    for(int i = head[u]; i != -1; i = edge[i].next)
    {
        int v = edge[i].to;
        if(v == pre) continue;
        dfs(v, u, dep+1);
        F[++cnt] = u;
        rmq[cnt] = dep;
    }
}
void LCA_init(int root, int node_num) //查询LCA前的初始化
{
    cnt = 0;
    dfs(root, root, 0);
    st.init(2*node_num-1);
}
int query_lca(int u, int v) //查询u, v的lca编号
{
    return F[st.query(P[u], P[v])];
}
bool flag[MAX];
int main()
{
    int T, N, u, v;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&N);
        init();
        memset(flag, false, sizeof(flag));
        for(int i = 1; i < N; ++i)
        {
            scanf("%d%d",&u,&v);
            addedge(u, v);
            addedge(v, u);
            flag[v] = true;
        }
        int root;
        for(int i = 1; i <= N; ++i)
            if(!flag[i])
            {
                root = i;
                break;
            }
        LCA_init(root, N);
        scanf("%d%d",&u, &v);
        printf("%d\n",query_lca(u, v));
    }
    return 0;
}

更快点的:

AC代码2(在线算法--倍增法):

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
const int MAX = 10010;
const int DEG = 20;

struct Edge
{
    int to, next;
}edge[MAX*2];    //别忘记*2
int head[MAX], tot;
void addedge(int u, int v)
{
    edge[tot].to = v;
    edge[tot].next = head[u];
    head[u] = tot++;
}
void init()
{
    tot = 0;
    memset(head, -1, sizeof(head));
}
int fa[MAX][DEG];//fa[i][j]表示结点i的第2^j个祖先
int deg[MAX];    //深度数组

void BFS(int root)
{
    queue<int> que;
    deg[root] = 0;
    fa[root][0] = root;
    que.push(root);
    while(!que.empty())
    {
        int tem = que.front();
        que.pop();
        for(int i = 1; i < DEG; ++i)
            fa[tem][i] = fa[fa[tem][i-1]][i-1];
        for(int i = head[tem]; i != -1; i = edge[i].next)
        {
            int v = edge[i].to;
            if(v == fa[tem][0]) continue;
            deg[v] = deg[tem] + 1;
            fa[v][0] = tem;
            que.push(v);
        }
    }
}
int LCA(int u, int v)
{
    if(deg[u] > deg[v]) swap(u, v);
    int hu = deg[u], hv = deg[v];
    int tu = u, tv = v;
    for(int det = hv-hu, i = 0; det ; det >>= 1, ++i)
    {
        if(det&1)
            tv = fa[tv][i];
    }
    if(tu == tv) return tu;
    for(int i = DEG - 1; i >= 0; --i)
    {
        if(fa[tu][i] == fa[tv][i])
            continue;
        tu = fa[tu][i];
        tv = fa[tv][i];
    }
    return fa[tu][0];
}
bool flag[MAX];
int main()
{
    int T, N, u, v;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&N);
        init();
        memset(flag, false, sizeof(flag));
        for(int i = 1; i < N; ++i)
        {
            scanf("%d%d",&u,&v);
            addedge(u, v);
            addedge(v, u);
            flag[v] = true;
        }
        int root;
        for(int i = 1; i <= N; ++i)
            if(!flag[i])
            {
                root = i;
                break;
            }
        BFS(root);
        scanf("%d%d",&u, &v);
        printf("%d\n",LCA(u, v));
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值