UVa 120 Stacks of Flapjacks 【排序】

题目链接:

UVa 120 Stacks of Flapjacks

Description:

Stacks and Queues are often considered the bread and butter of data structures and find use in architecture, parsing, operating systems, and discrete event simulation. Stacks are also important in the theory of formal languages.
This problem involves both butter and sustenance in the form of pancakes rather than bread in addition to a finicky server who flips pancakes according to a unique, but complete set of rules.
Given a stack of pancakes, you are to write a program that indicates how the stack can be sorted so that the largest pancake is on the bottom and the smallest pancake is on the top. The size of a pancake is given by the pancake’s diameter. All pancakes in a stack have different diameters.
Sorting a stack is done by a sequence of pancake “flips”. A flip consists of inserting a spatula between two pancakes in a stack and flipping (reversing) all the pancakes on the spatula (reversing the sub-stack). A flip is specified by giving the position of the pancake on the bottom of the sub-stack to be flipped (relative to the whole stack). The pancake on the bottom of the whole stack has position 1 and the pancake on the top of a stack of n pancakes has position n.
A stack is specified by giving the diameter of each pancake in the stack in the order in which the pancakes appear.
For example, consider the three stacks of pancakes below (in which pancake 8 is the top-most pancake of the left stack):
8 7 2
4 6 5
6 4 8
7 8 4
5 5 6
2 2 7
The stack on the left can be transformed to the stack in the middle via flip(3). The middle stack can be transformed into the right stack via the command flip(1).

Input

The input consists of a sequence of stacks of pancakes. Each stack will consist of between 1 and 30 pancakes and each pancake will have an integer diameter between 1 and 100. The input is terminated by end-of-file. Each stack is given as a single line of input with the top pancake on a stack appearing first on a line, the bottom pancake appearing last, and all pancakes separated by a space.

Output

For each stack of pancakes, the output should echo the original stack on one line, followed by some sequence of flips that results in the stack of pancakes being sorted so that the largest diameter pancake is on the bottom and the smallest on top. For each stack the sequence of flips should be terminated by a ‘0’ (indicating no more flips necessary). Once a stack is sorted, no more flips should be made.

Sample Input

1 2 3 4 5
5 4 3 2 1
5 1 2 3 4

Sample Output

1 2 3 4 5
0
5 4 3 2 1
1 0
5 1 2 3 4
1 2 0

题目大意:

这里有一堆煎饼,给出从顶端到底端排列的每个煎饼的尺寸,要求经过多次翻转使之成为从顶到底尺寸依次增大。【翻转的过程是选择一个位置k,将顶端到k位置的全部煎饼翻转一下位置,如1 2 3 4 5,从4处翻转,则得到的序列为4 3 2 1 5】输出每次翻转时的位置,以0结尾。

解题思路:

我们每次从序列中找到最大的数,看他是否在应该在的位置,如果在,则考虑下一个最大的数;如果不在则看他是否在顶端(因为每次能控制的就是将顶端的煎饼翻转到应在的位置)若在顶端就直接翻转到应在的位置,否则先将他翻到顶端再翻转到应在的位置。

Mycode:

#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const int MAX = 10005;
const int MOD = 1e9+7;
const int INF = 0x3f3f3f3f;

int tot;
int a[35];
string s;
void solve(int p)
{
    for(int i = 0; i < p - i; ++i)
        swap(a[i], a[p-i]);
    cout << tot - p << " ";
}
int main()
{
    while(getline(cin, s))
    {
        cout << s << endl;
        tot = 0;
        stringstream ss (s);
        while(ss >> a[tot])
        {
            ++tot;
        }
        for(int i = tot -1; i > 0; --i)
        {
            int p = max_element(a, a + i + 1) - a;
            if(p == i)  continue;   //已经在应有位置
            if(p > 0)   solve(p);   //将这个煎饼翻到最顶端
            solve(i);               //将最顶端的煎饼翻到应有位置
        }
        cout << 0 << endl;
    }
    return 0;
}

skill:

max_element 数组中的元素在某范围内的最大值
min_element 数组中的元素在某范围内的最小值
nth_element 求第n小的元素,并把它放在第n位置上,比这个元素小的元素都排在这个元素之前,比这个元素大的元素都排在这个元素之后,但不能保证他们是有序

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值