POJ 2398 计算几何+二分+排序

Toy Storage
Time Limit: 1000MS  Memory Limit: 65536K
Total Submissions: 3953  Accepted: 2334

Description

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:



We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.
Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.

A line consisting of a single 0 terminates the input.
Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.
Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1

Source

Tehran 2003 Preliminary

<span style="color:#6600cc;">/********************************************
    author    : Grant Yuan
    time      : 2014/8/19 0:48
    algorithm : 计算几何+二分+排序
    source    : POJ 2398
*********************************************/

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#define MAX 1007

using namespace std;
int n,m,x1,y1,x2,y2,x3,y3;
int res[MAX],ans;
struct Point
{
    int x,y;
    Point(){}
    Point(int _x,int _y)
    {
        x=_x;
        y=_y;
    }
    Point operator -(const Point &b)
    {
        return Point(x-b.x,y-b.y);
    }
    int operator *(const Point &b)
    {
        return x*b.x+y*b.y;
    }
    int operator ^(const Point &b)
    {
        return x*b.y-y*b.x;
    }
};

struct Line
{
    Point p1,p2;
    Line(){}
    Line(Point a,Point b)
    {
        p1=a;p2=b;
    }
};

Line line[MAX];

int cmp(Line l1,Line l2)
{
    return l1.p1.x<l2.p1.x;
}
int xmult(Point p0,Point p1,Point p2)
{
   return (p1-p0)^(p2-p0);
}

int main()
{
    while(~scanf("%d",&n)&&n)
    {
        if(n==0) break;
        memset(res,0,sizeof(res));
        memset(line,0,sizeof(line));
        scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
        int Ui,Li;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&Ui,&Li);
            line[i]=Line(Point(Ui,y1),Point(Li,y2));
        }
        line[n]=Line(Point(x2,y1),Point(x2,y2));
        sort(line,line+n+1,cmp);
        while(m--){
           Point p0;
           scanf("%d%d",&x3,&y3);
           p0=Point(x3,y3);
           int l,r,mid;
           l=0;r=n;
           while(l<=r)
           {
               mid=(l+r)>>1;
               if(xmult(p0,line[mid].p1,line[mid].p2)<0)
               {
                   ans=mid;
                   r=mid-1;
               }
               else l=mid+1;
           }
           res[ans]++;
        }
        sort(res,res+n+1);
        ans=0;
        printf("Box\n");
        int tem=res[0];
        for(int i=0;i<=n;i++)
        {
           if(res[i]==tem) ans++;
           else{
              if(res[i-1]) printf("%d: %d\n",res[i-1],ans);
              ans=1;
              tem=res[i];
           }
        }
        if(res[n]) printf("%d: %d\n",res[n],ans);
    }
    return 0;
}


</span>

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值