POJ 1979-Red and Black

Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 24447 Accepted: 13175

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
小结:

        dfs水题,没什么好说的...基本看看代码就能理解了.

以下是AC代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int row,col,ans;
int dir[4][2]={1,0,0,1,-1,0,0,-1};
int f[30][30];
char map[30][30];
int ok(int a,int b)
{
    if(a<1||b<1||a>row||b>col||map[a][b]=='#')
    return 0;
    return 1;
}
void dfs(int num1,int num2)
{
    ans++;
    f[num1][num2]=1;
    for(int i=0;i<4;i++)
    {
        int x=num1+dir[i][0];
        int y=num2+dir[i][1];
        if(ok(x,y)&&!f[x][y])
        {
            dfs(x,y);
        }
    }
}
int main()
{
    int sx,sy;
    while(~scanf("%d%d",&col,&row))
    {
        if(row==0&&col==0)
        break;
        getchar();
        memset(f,0,sizeof(f));
        ans=0;
        for(int i=1;i<=row;i++)
        {
            scanf("%s",map[i]+1);
        }
        for(int i=1;i<=row;i++)
        {
            for(int j=1;j<=col;j++)
            {
                if(map[i][j]=='@')
                {
                    sx=i;
                    sy=j;
                    break;
                }
            }
        }
        dfs(sx,sy);
        printf("%d\n",ans);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值