Eight

Eight

The 15-puzzle has been around for over 100 years; even if you don’t know it by that name, you’ve seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let’s call the missing tile ‘x’; the object of the puzzle is to arrange the tiles so that they are ordered as:

1 2 3 4
5 6 7 8
9 10 11 12
13 14 15 x

where the only legal operation is to exchange ‘x’ with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:

1 2 3 4 1 2 3 4 1 2 3 4 1 2 3 4
5 6 7 8 5 6 7 8 5 6 7 8 5 6 7 8
9 x 10 12 9 10 x 12 9 10 11 12 9 10 11 12
13 14 11 15 13 14 11 15 13 14 x 15 13 14 15 x
r-> d-> r->

The letters in the previous row indicate which neighbor of the ‘x’ tile is swapped with the ‘x’ tile at each step; legal values are ‘r’,‘l’,‘u’ and ‘d’, for right, left, up, and down, respectively.

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and

frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing ‘x’ tile, of course).

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three

arrangement.

Input
You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus ‘x’. For example, this puzzle

1 2 3

x 4 6

7 5 8

is described by this list:

1 2 3 x 4 6 7 5 8

Output
You will print to standard output either the word ``unsolvable’’, if the puzzle has no solution, or a string consisting entirely of the letters ‘r’, ‘l’, ‘u’ and ‘d’ that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.

    Sample Input
    2  3  4  1  5  x  7  6  8

    Sample Output
    ullddrurdllurdruldr

题意:典型的八数码问题,就是给了一个3*3的矩阵,求最少要对 “x” 经过怎样的移动能使矩阵变成 1 2 3 4 5 6 7 8 x,输出最少的移动步骤。

代码:

#include<stdio.h>
#include<map>
#include<queue>
#include<string>
#include<string.h>
#include<algorithm>
using namespace std;
typedef long long ll;
map<ll,string>m;
map<ll,int>n;
struct node
{
    string c;
    int s[3][3];
    int x,y;
};
void bfs()
{
    queue<node>q;
    node u,v;
    int p[4][2]={0,1,0,-1,1,0,-1,0};
    for(int i=0;i<3;i++)
        for(int j=0;j<3;j++)
        u.s[i][j]=i*3+j+1;
    u.s[2][2]=0;
    u.x=2;
    u.y=2;
    q.push(u);
    n[123456780]=1;
    while(!q.empty())
    {
        u=q.front();
        q.pop();
        for(int i=0;i<4;i++)
        {
            v.x=u.x+p[i][0];
            v.y=u.y+p[i][1];
            if(v.x>2||v.x<0||v.y>2||v.y<0)
                continue;
            for(int j=0;j<3;j++)
                for(int k=0;k<3;k++)
                v.s[j][k]=u.s[j][k];
            swap(v.s[v.x][v.y],v.s[u.x][u.y]);
            ll sum=1;
            for(int j=0;j<3;j++)
                for(int k=0;k<3;k++)
                sum=sum*10+v.s[j][k];
            if(n[sum])
                continue;
            n[sum]=1;
            if(i==0)
                v.c=u.c+'l';
            if(i==1)
                v.c=u.c+'r';
            if(i==2)
                v.c=u.c+'u';
            if(i==3)
                v.c=u.c+'d';
            q.push(v);
            m[sum]=v.c;
        }
    }
}
int main()
{
    bfs();
    char a[50];
    while(gets(a))
    {
        int k=strlen(a);
        ll sum=1;
        for(int i=0;i<k;i++)
        {
            if(a[i]>='1'&&a[i]<='9')
                sum=sum*10+(a[i]-'0');
            if(a[i]=='x')
                sum*=10;
        }
        if(!n[sum])
            printf("unsolvable\n");
        else
        {
            string ss=m[sum];
            for(int i=ss.length()-1;i>=0;i--)
                printf("%c",ss[i]);
            printf("\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值