Addition Chains

Addition Chains

An addition chain for n is an integer sequence <a0, a1,a2,…,am> with the following four properties:

a0 = 1
am = n
a0 < a1 < a2 < … < am-1 < am
For each k (1 <= k <= m) there exist two (not necessarily different) integers i and j (0 <= i, j <= k-1) with ak = ai + aj

You are given an integer n. Your job is to construct an addition chain for n with minimal length. If there is more than one such sequence, any one is acceptable.

For example, <1, 2, 3, 5> and <1, 2, 4, 5> are both valid solutions when you are asked for an addition chain for 5.

Input

The input will contain one or more test cases. Each test case consists of one line containing one integer n (1 <= n <= 100). Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the required integer sequence. Separate the numbers by one blank.

Sample Input

 5
 7
 12
 15
 77
 0 

Sample Output

 1 2 4 5
 1 2 4 6 7
 1 2 4 8 12
 1 2 4 5 10 15
 1 2 4 8 9 17 34 68 77

题意:
给你一个数,问你从1开始,最少几个数能加到这个数,其中的一个数(除了1)必须能被其中的两个数相加得到。
思路:既然要最少的,那么这些数越大越好,所以咱们可以倒着搜。
代码:

#include<stdio.h>
#include<string.h>
int a[110];
int s,c[110],n;
void dfs(int x,int b)
{
    if(x>n||b>=s)
        return;
    if(x==n&&b<s)
    {
        s=b;
        for(int i=0; i<s; i++)
            c[i]=a[i];
        return;
    }
    for(int i=b-1; i>=0; i--)
    {
        a[b]=x+a[i];
        dfs(a[b],b+1);
        a[b]=0;
    }
    return;
}
int main()
{
    while(~scanf("%d",&n),n)
    {
        memset(a,0,sizeof(a));
        memset(c,0,sizeof(c));
        s=110;
        if(n==1)
        {
            printf("1\n");
            continue;
        }
        a[0]=1,a[1]=2;
        dfs(2,2);
        printf("%d",c[0]);
        for(int i=1;i<s;i++)
            printf(" %d",c[i]);
        printf("\n");
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值