ZCMU-1415

1415: Box of Bricks

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 222   Solved: 101
[ Submit][ Status][ Web Board]

Description

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you should make all stacks the same height. Then you would have a real wall.'', she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?

Input

The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

Output

For each set, first print the number of the set, as shown in the sample output. Then print the line ``The minimum number of moves is k.'', where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height. 

Output a blank line after each set.

Sample Input

6
5 2 4 1 7 5
0

Sample Output

Set #1
The minimum number of moves is 5.

【解析】
这道题呢其实就是给你砖头数问你要移动多少块,就是说你先算出平均的高度,这个时候我们模拟一下会发现其实就是把比平均高的给移动走就存在这样的过程比平均高度高的移动移动走的砖头有的其实就是给了比平均高度矮的,有的是直接移动走了。
#include <stdio.h>
int main()
{
    int n,i,count1=0,sum1,average,sum2;
    int a[100];
 while(scanf("%d", &n)&&n!=0)
 {
      sum1=sum2= 0;
      count1++;
     for(i=0; i<n; i++)
  {
       scanf("%d", &a[i]);
  }
  for(i=0; i<n; i++)
  {
        sum1+=a[i];     //计算总数
  }
  average=sum1/n;
  for(i=0; i<n; i++)   //计算要移动的箱子数
  {
      if(a[i]>average)
   {
       sum2=sum2+a[i]-average;
   }

  }
printf("Set #%d\n", count1);
  printf("The minimum number of moves is %d.\n\n", sum2);
 }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值