ZCMU-1379-The Black Hole of Numbers

Description

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the "black hole" of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output

If all the 4 digits of N are the same, print in one line the equation "N - N = 0000". Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input

6767
2222

Sample Output

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
2222 - 2222 = 0000
【解析】
这道题就是将所给的数分成四个数字就行排序相减。排序所得的最大数减去排序所得的最小数。
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
bool cmp1(int a,int b)
{
    return a>b;//以降序来排

}
bool cmp2(int a,int b)
{
    return a<b;//以升序排序来排序
}
int main()
{   int n,i=0,temp,len;
    while(~scanf("%d",&n))
    {
    int a[4]={0};
    int b[4]={0};
    len=3;
    while(n!=0&&len!=-1)
    {
        a[len]=n%10;//把数字的每一位分别放在一个数组里面
        n=n/10;
        len--;
    }
    len=3;
    if(a[0]==a[1]&&a[1]==a[2]&&a[2]==a[3])
    {
        cout<<a[0]<<a[1]<<a[2]<<a[3]<<" "<<"-"<<" "<<a[0]<<a[1]<<a[2]<<a[3]<<" "<<"="<<" "<<"0000"<<endl;
        //如果四位都相等则直接输出0000
        continue;
    }
    int result=0;
    while(result!=6174)//此处循环判断最后是否为6174
    {
        len=3;
        for(i=0;i<=3;i++)
        {
            b[i]=a[i];//把a数组的元素也给了b数组
        }
        sort(a,a+4,cmp1);//a是高位
        sort(b,b+4,cmp2);//b是低位
        result=a[0]*1000+a[1]*100+a[2]*10+a[3]-b[0]*1000-b[1]*100-b[2]*10-b[3];//计算所得的结果
        cout<<a[0]<<a[1]<<a[2]<<a[3]<<" "<<"-"<<" "<<b[0]<<b[1]<<b[2]<<b[3]<<" "<<"="<<" ";
        temp=result;
        for(i=0;i<4;i++)
            a[i]=0;
        while(temp!=0&&len!=-1)
        {
            a[len--]=temp%10;//继续把结果给数组然后继续操作如果还没到6174的话
            temp/=10;
        }
        cout<<a[0]<<a[1]<<a[2]<<a[3]<<endl;
    }
    }
    return 0;

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值