ZCMU-Problem C - Sumsets

Problem C: Problem C - Sumsets

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 26   Solved: 18
[ Submit][ Status][ Web Board]

Description

Problem C - Sumsets

Given S, a set of integers, find the largest d such that a + b + c = d where a, b, c, and d are distinct elements of S.

Input

Several S, each consisting of a line containing an integer 1 <= n <= 1000 indicating the number of elements in S, followed by the elements of S, one per line. Each element of S is a distinct integer between -536870912 and +536870911 inclusive. The last line of input contains 0.

Output

For each S, a single line containing d, or a single line containing "no solution".

Sample Input

5
2
3
5
7
12
5
2
16
64
256
1024
0

Sample Output

12
no solution
【解析】
这道题的意思就是给我们一个集合,然后让我们算集合当中有没有存在a+b+c=d,如果有存在多个的要保证d是最大的
那么其实我们就可以先给这个集合的元素先排序,然后再让把a+b+c=d化成a+b=d-c,这样我们可以通过二分查找来查
找a和b的值,我们让c取的是在a,b,c当中最大的值会比较好算...果然很多都可以用二分法来求..还是自己太菜了..
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    int n,i,j,a[1001],sum,left,right,m;
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
        memset(a,0,sizeof(a));
        m=-1;
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a,a+n);//排序整个集合中的元素
        for(i=n-1;i>=0;i--)//d的取值
        {
            for(j=n-1;j>=0;j--)//c的取值
            {
                if(i==j)
                    continue;
                sum=a[i]-a[j];//a+b的值
                left=0,right=j-1;//从0开始到j-1寻找a和b的值
                while(left<right)
                {
                    if(a[left]+a[right]==sum)
                    {
                        m=a[i];
                    goto loop;
                    }
                    else if(a[left]+a[right]>sum)
                    {
                        right--;
                    }
                    else
                    {
                        left++;
                    }
                }
            }
        }
        loop:
        if(m==-1)
            printf("no solution\n");//没有这样的值
        else
            printf("%d\n",m);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值