ZCMU-Problem E - Ones

Problem E: Problem E - Ones

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 27   Solved: 24
[ Submit][ Status][ Web Board]

Description

Given any integer 0 <= n <= 10000 not divisible by 2 or 5, some multiple of n is a number which in decimal notation is a sequence of 1's. How many digits are in the smallest such a multiple of n?

Input

Output

Sample Input

3
7
9901

Sample Output

3
6
12

HINT

【解析】
这道题的意思其实就是让我们输出要有多少个1才能是输入的n的倍数。比如第一个是输入3,111才是3的倍数所以输出3表示有3个1.所以我们只需要枚举1,11,111等这些全是1的数就可以了。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    int n,count1=0;
    long long m;
    while(~scanf("%d",&n))
    {
        m=1;
        count1=1;
        while(m%=n)
        {
            m=m*10+1;
            count1++;
        }
    printf("%d\n",count1);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值