1899-Virtual Friends(map+并查集) ZCMU

Description

These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends.

Your task is to observe the interactions on such a website and keep track of the size of each person's network.

Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.

Input

The first line of input contains one integer specifying the number of test cases to follow. Each test case begins with a line containing an integer F, the number of friendships formed, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).

Output

Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.

Sample Input

1

3

Fred Barney

Barney Betty

Betty Wilma

Sample Output

2

3

4

代码

#include<bits/stdc++.h>
const int MAX=100005;
using namespace std;
int farther[MAX],fri[MAX];
//fri[i]为编号为i的人的朋友圈人数
map<string,int> mark; //map记录每个人的编号
//初始化
void init()
{
    for(int i=1;i<=MAX;i++)
    {
        farther[i]=i; fri[i]=1; //每个人初始的朋友圈都是1,因为只有自己
    }
    mark.clear();
}
//并查集找父亲
int getfarther(int x)
{
    if(x!=farther[x])
        farther[x]=getfarther(farther[x]);
    return farther[x];
}
void union_set(int x,int y)
{
    x=getfarther(x);
    y=getfarther(y);
    if(x==y) //如果两人已经是朋友,那么只要输出一个人的朋友圈就可
        printf("%d\n",fri[x]);
    else 结交了朋友圈外的朋友的时候,直接指定一个人的朋友圈为最后要输出的朋友圈,然后输出他们两个的朋友圈之和
    {
        farther[x]=y;
        fri[y]+=fri[x];
        printf("%d\n",fri[y]);
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,num=1;
        string p1,p2;
        scanf("%d",&n); init();
        for(int i=1;i<=n;i++)
        {
            cin>>p1>>p2;
            if(!mark[p1])
                mark[p1]=num++;
            if(!mark[p2])
                mark[p2]=num++;
            union_set(mark[p1],mark[p2]);
        }
    }
    return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值