ZOJ1016

Description

Let S = s1 s2 ... s2n be a well-formed string of parentheses. S can be encoded in two different ways:

  • By an integer sequence P = p1 p2 ... pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
  • By an integer sequence W = w1 w2 ... wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S (((()()())))
P-sequence 4 5 6666
W-sequence 1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input


 The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

 

Output



The output consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

 

Sample Input

2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9

Sample Output


1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

思路

序列P  :每个右括号之前左括号的个数

序列W :每个右括号与和它匹配的左括号之间有几个右括号(包括它自己)

解题步骤:

1.根据所给的序列P还原括号序列

2.利用结构,结构体变量声明为index(用来记录每个左括号的下标)

3.声明一个栈

4.遍历还原的括号序列,当遇到str[i]=='('时,声明一个对象e,e.index=i,并将e压入栈.当str[i]==')',首先记录栈顶元素的下标,再弹出栈顶元素,中间右括号的个数 =(i-1-index)/2+1x

代码

#include<stdio.h>
#include<string.h>
#include<stack>
#include<iostream>
using namespace std;
struct Node{
  int index;
};
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        char str[1000]; int num[30],n,i;
        scanf("%d",&n);
        for(i=1;i<=n;i++)
        {
           scanf("%d",&num[i]);
        }
        int len=1; num[0]=0;
        stack<Node> s;
        for(int i=1;i<=n;i++)
        {
            int temp=num[i]-num[i-1];
            while(temp!=0)
            {
                str[len]='(';
                len+=1; temp-=1;
            }
            str[len]=')';
            len+=1;
        }
        int flag=0;
        for(int i=1;i<len;i++)
        {
            if(str[i]=='(')
            {
                Node e;
                e.index=i;
                s.push(e);
            }
            else
            {
                Node temp=s.top();
                int number=(i-1-temp.index)/2;
                if(!flag)
                {
                   printf("%d",number+1);
                   flag=1;
                }
                else
                    printf(" %d",number+1);
                s.pop();
            }
        }
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值