HDU1757矩阵的简单运用

原题http://acm.hdu.edu.cn/showproblem.php?pid=1757

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2526    Accepted Submission(s): 1469


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.


 

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.


 

Output
For each case, output f(k) % m in one line.


 

Sample Input
  
  
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0


 

Sample Output
  
  
45 104
//本题只要把矩阵构造出来,接下来的就是套模板了
//构建的矩阵相乘的类型为AAAAAAB,B为已知的函数前几项
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <math.h>
#include <algorithm>
#include <iostream>
#include <stack>
#include <queue>
#include <deque>
#include <vector>
#include <map>
#include <set>
using namespace std;
#define max 15
int k,mod;

struct Matrix{
	int m[max][max];
};

Matrix unit,init;

void Init(){
	int i;
	memset(init.m,0,sizeof(init.m));
	for(i=1;i<10;i++){
		init.m[i][i-1] = 1;//自己构建的那个矩阵
	}
	memset(unit.m,0,sizeof(unit.m));
	for(i=0;i<10;i++){
		unit.m[i][i] = 1;
	}
}

Matrix Mul(Matrix a,Matrix b){
	Matrix c;
	int i,j,k;
	for(i=0;i<10;i++){
		for(j=0;j<10;j++){
			c.m[i][j] = 0;
			for(k=0;k<10;k++){
				c.m[i][j]+=(a.m[i][k]*b.m[k][j])%mod;
			}
			c.m[i][j]%=mod;
		}
	}
	
	return c;
}

Matrix Pow(Matrix a,Matrix b,int x){
	while(x){
		if(x&1){
			b = Mul(a,b);
		}
		a = Mul(a,a);
		x>>=1;
	}
	
	return b;
}

int main(){
	int i;

	while(~scanf("%d%d",&k,&mod)){
		Init();
		for(i=0;i<10;i++){
			scanf("%d",&init.m[0][i]);
		}
		if(k < 10){
			printf("%d\n",k%mod);
		}
		Matrix res = Pow(init,unit,k-9);
		int ans = 0;
		for(i=0;i<10;i++){
			ans+=(res.m[0][i]*(9-i))%mod;//因为这个函数的前10项为9,8,7,6,5,4,3,2,1,0
		}
		ans%=mod;
		printf("%d\n",ans);
	}

	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值