Sequence in the Pocket

给定一个整数序列,DreamGrid需要通过将元素移至序列开头来实现非递减顺序。求达成这一目标的最小操作次数。题目包含多组测试用例,每组用例给出序列长度及序列本身,保证所有序列长度之和不超过1e6。对于每个用例,输出一行表示所需操作次数。示例解释了操作过程。
摘要由CSDN通过智能技术生成

DreamGrid has just found an integer sequence a1,a2……an  in his right pocket. As DreamGrid is bored, he decides to play with the sequence. He can perform the following operation any number of times (including zero time): select an element and move it to the beginning of the sequence.

What's the minimum number of operations needed to make the sequence non-decreasing?

Input

There are multiple test cases. The first line of the input contains an integer T, indicating the number of test cases. For each test case:

The first line contains an integer n (1<=n<=1e5), indicating the length of the sequence.

The second line contains n integers a1,a2……an  (1<=ai<=1e9), indicating the given sequence.

It's guaranteed that the sum of n of all test cases will not exceed 1e6.

Output

For each test case output one line containing one integer, indicating the answer.

Sample Input

2
4
1 3 2 4
5
2 3 3 5 5
Sample Output

2
0

Hint

For the first sample test case, move the 3rd element to the front (so the sequence become {2, 1, 3, 4}), then move the 2nd element to the front (so the sequence become {1, 2, 3, 4}). Now the sequence is non-decreasing.

For the second sample test case, as the sequence is already sorted, no operation is needed.

题意:问最少几次操作(将一个数直接移到序列最前面)可以将整个序列变成非递减的。

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <sstream>
#include <cstdio>
#include <vector>
#include <string>
#include <cmath>
#include <stack>
#include <queue>
#include <map>
#include <set>
#define MAX 0x3f3f3f3f
#define fori(a,b) for(int i=a;i<=b;i++)
#define forj(a,b) for(int j=a;j<=b;j++)
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
typedef long long LL;
const double PI = acos(-1);
const int M=1e5+10;
int a[M],b[M];
int main()
{
    //freopen("//home//acm//桌面//in","r",stdin);
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        LL ans=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
            b[i]=a[i];
        }
        sort(b+1,b+n+1);
        int k=n;
        for(int i=n; i>=1; i--)
        {
            if(a[i]<b[k])
            {
                ans++;
            }
            else
                k--;
        }
        printf("%lld\n",ans);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值