What day is it
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2274 Accepted Submission(s): 667
Problem Description
Today is Saturday, 17th Nov,2007. Now, if i tell you a date, can you tell me what day it is ?
Input
There are multiply cases.
One line is one case.
There are three integers, year(0<year<10000), month(0<=month<13), day(0<=day<32).
One line is one case.
There are three integers, year(0<year<10000), month(0<=month<13), day(0<=day<32).
Output
Output one line.
if the date is illegal, you should output "illegal". Or, you should output what day it is.
if the date is illegal, you should output "illegal". Or, you should output what day it is.
Sample Input
2007 11 17
Sample Output
Saturday
思路:0年1月1日是星期六。每个日期都跟它比。
AC代码:
#include<iostream>
#include<string.h>
#define lev(n) (n%400==0||(n%4==0&&n%100!=0))
using namespace std;
int an[2][13]={{0,31,28,31,30,31,30,31,31,30,31,30,31},
{0,31,29,31,30,31,30,31,31,30,31,30,31}};
int illegal(int y,int m,int d)
{
if(m*d==0)return 1;
if(d>an[lev(y)][m]) return 1;
return 0;
}
int thisyear(int y,int m,int d)
{
int i,s=0;
for(i=0;i<m;i++)
s+=an[lev(y)][i];
return (s+d)%7;
}
int calc (int y,int m,int d)
{
int i,s=0;
for(i=0;i<y;i++)
s+=lev(i)?366:365;
return (s+thisyear(y,m,d)+4)%7;
}
int main()
{
int y,m,d;
char c[7][10]={"Monday","Tuesday","Wednesday",
"Thursday","Friday","Saturday","Sunday"};
while(scanf("%d%d%d",&y,&m,&d)!=EOF)
{
if(illegal(y,m,d)) puts("illegal");
else puts(c[calc(y,m,d)]);
}
return 0;
}