HDU 1042 N!

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34337    Accepted Submission(s): 9604


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 6
 

AC代码:

#include<iostream>
using namespace std;
int a[40000];
int main()
{
    int N,i,j,pre;
    while(cin>>N)
    {
        a[0]=1;
        a[1]=1;
        if(N==0||N==1){cout<<1<<endl;continue;}
        for(i=2;i<=N;i++)
        {
            pre=0;
            for(j=1;j<=a[0];j++)
            {
                a[j]=a[j]*i;
                a[j]+=pre;//加上进位
                pre=a[j]/10;//进位值
                a[j]%=10;//本位
            }
            while(pre)
            {
                a[j]=pre%10;
                a[0]=j;
                pre/=10;
                j++;
            }
        }
        for(i=a[0];i>=1;i--)
        {cout<<a[i];}
        cout<<endl;
    }
    return 0;
}


 


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值