Eclipse编译项目时errors occurred during the build.

1.在Eclipse运行项目时遇见的这个errors occurred during the build. errors running builder "android package builder" on project xxx. com/android/dx/command/dexer/Main: Unsupported major.minor version 52.0.



JDK版本不一致造成的,指的是高版本的JDK编译的class不能放在低版本的JDK上运行。

不同的JDK版本使用的 major.minor version(主次版本号) 不同,所以会导致这个错误。
JavaSE 8 = 52 (0x34 hex),
JavaSE 7 = 51 (0x33 hex),
JavaSE 6 = 50 (0x32 hex),
JavaSE 5 = 49 (0x31 hex),
J2SE 1.4 = 48 (0x30 hex),
J2SE 1.3 = 47 (0x2F hex),
J2SE 1.2 = 46 (0x2E hex),
J2SE 1.1 = 45 (0x2D hex)
eclipse指定jdk1.8版本。

解决方法就是:

1.安装jdk8,重新配置一下 环境

2.修改一下 Eclipse的 配置文件 Eclipse.ini,

我是用的第一个解决方法,第二我试了一下,对于我的这个不行,估计只适合其中一部分.

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/ZFY11/article/details/79963392
个人分类: android
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭