PAT (Advanced Level)1007 Maximum Subsequence Sum (25分)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

思路

这是动态规划里的最大连续子序列和问题,先用num数组把数据存下来,再用maxsum数组存储以i位为序列末尾的最大子序列和,采用pos数组存储对应的first和last,最后再把maxsum数组里的最大值读出来就好了。另外要注意的是,当全部序列为负数时,最大和为0,输出第一位和最后一位数。这里要用flag处理一下,不然会有一个测试点通过不了。

代码

#include<stdio.h>
#include<vector>
#include<map>
using namespace std;
int main(){
	int n;
	vector<int> num,maxsum;
	vector<pair<int,int> > pos;
	bool flag=true;
	scanf("%d",&n);
	num.resize(n);
	maxsum.resize(n);
	pos.resize(n);
	for(int i=0;i<n;i++){
		scanf("%d",&num[i]);
		if(num[i]>=0)
			flag=false;
	}
	if(flag){
		printf("%d %d %d",0,num[0],num[n-1]);
		return 0;
	}
	maxsum[0]=num[0];
	pos[0]=make_pair(num[0],num[0]);
	for(int i=1;i<n;i++){
		if(maxsum[i-1]<0){
			maxsum[i]=num[i];
			pos[i]=make_pair(num[i],num[i]);
		}else{
			maxsum[i]=maxsum[i-1]+num[i];
			pos[i]=make_pair(pos[i-1].first,num[i]);
		}
	}
	int temp=0;
	for(int i=1;i<n;i++)
		if(maxsum[i]>maxsum[temp])
			temp=i;
	printf("%d %d %d",maxsum[temp],pos[temp].first,pos[temp].second);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值