Title:
An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.
Input
Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.
Output
For each problem instance, output consists of one line. This line should be one of the following three:
Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.
where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.
Sample Input
4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0
Sample Output
Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.
思路:
拓扑排序模板题目
注意点:
输出的4表示第四行确定了关系。输出的2表示第二行出现了循环
代码如下:
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <queue>
using namespace std;
int init[30],graph[30][30];
int n,m;
queue<int> List;
char x,y;
int pp()
{
memset(init,0,sizeof(init));
///表示解封的条件数目
for(int i=0; i<n; i++)
{
for(int j=0; j<n; j++)
{
if(graph[i][j] == 1)
init[j]++;
}
}
queue<int> q;
int flag = 0;
for(int k=0; k<n;){
int cnt = 0;
for(int j=0; j<n; j++){
if(init[j] == 0)
cnt++;
}
///出现了环的问题
if(cnt == 0)
return 2;
///表示存在多个0的情况,表示路径之间不连接,存在多个独立路径问题,要么就是环,要么就是条件不全。需再判断,此处不能放回
if( cnt > 1 )
flag = 3;
for(int i=0; i<n; i++){
if(init[i] == 0){
q.push(i);
k++;
for(int j=0; j<n; j++)
{
if(graph[i][j] == 1)
init[j]--;
}
init[i] = -1;
break;
}
}
}
if(flag != 3){
List = q;
return 1;
}
else
return 3;
}
int main()
{
while(cin>>n>>m)
{
if(n == 0 && m ==0)
break;
memset(graph,0,sizeof(graph));
int flag = 0;
for(int i=0; i<m; i++)
{
cin>>x>>y>>y;
graph[x - 'A'][y - 'A'] = 1;
if(flag == 2 || flag == 1)
continue;
flag = pp();
if (flag == 1)
{
cout << "Sorted sequence determined after " << i+1 << " relations: ";
while (!List.empty())
{
cout << (char)('A' + List.front());
List.pop();
}
cout << "." << endl;
}
else if (flag == 2)
cout << "Inconsistency found after " << i+1 << " relations." << endl;
}
if(flag == 3)
cout<<"Sorted sequence cannot be determined."<<endl;
}
return 0;
}