Perfect Sequence(upper_bound

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:
Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10
​5
​​ ) is the number of integers in the sequence, and p (≤10
​9
​​ ) is the parameter. In the second line there are N positive integers, each is no greater than 10
​9
​​ .

Output Specification:
For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9
Sample Output:
8

#include<bits/stdc++.h>
#include <iostream>
#include <map>
#include <string>
#include<vector>
#include<stack>
using namespace std;
int main() {
    int n,p;
    cin>>n>>p;
    long long a[n];
    for(int i=0;i<n;i++)
    {
    	cin>>a[i];
	}
	sort(a,a+n);
	int ans=0;
	
	for(int i=0;i<n;i++)
	{
		ans=max((int)(upper_bound(a,a+n,a[i]*p)-(a+i)),ans);
	 } 
	 cout<<ans<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
lower_boundupper_bound是C++ STL中的两个函数,都用于查找一个有序序列中特定值的位置。 lower_bound函数返回指向第一个不小于给定值的元素的迭代器,也就是说,如果该值存在于序列中,返回指向它的迭代器;如果不存在,返回指向第一个大于它的元素的迭代器。 upper_bound函数返回指向第一个大于给定值的元素的迭代器,也就是说,如果该值存在于序列中,返回指向它后面一个元素的迭代器;如果不存在,返回指向第一个大于它的元素的迭代器。 举个例子,假设有一个有序序列:{1, 2, 3, 4, 4, 4, 5, 6}。 1. 使用lower_bound函数查找元素4的位置: ```c++ vector<int> v{1, 2, 3, 4, 4, 4, 5, 6}; auto it = lower_bound(v.begin(), v.end(), 4); if (it != v.end() && *it == 4) { cout << "4 found at position: " << it - v.begin() << endl; } else { cout << "4 not found" << endl; } ``` 输出结果:4 found at position: 3 2. 使用upper_bound函数查找元素4的位置: ```c++ vector<int> v{1, 2, 3, 4, 4, 4, 5, 6}; auto it = upper_bound(v.begin(), v.end(), 4); if (it != v.end()) { cout << "First element greater than 4 found at position: " << it - v.begin() << endl; } else { cout << "4 is the largest element in the sequence" << endl; } ``` 输出结果:First element greater than 4 found at position: 6 注意,当序列中不存在要查找的元素时,lower_boundupper_bound返回的迭代器都指向第一个大于它的元素的位置。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值