1085 Perfect Sequence (25point(s))

文章目录

问题

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.
Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10​5​​) is the number of integers in the sequence, and p (≤10​9​​) is the parameter. In the second line there are N positive integers, each is no greater than 10​9​​.
Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.
Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

解决方法

分析:二分法

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int main()
{
	long long n, p, tmp = 0, final = 0;
	cin >> n >> p;
	vector<int>v(n);
	for (int i = 0; i < n; i++) {
		cin >> v[i];
	}
	sort(v.begin(), v.end());
	for (int i = 0; i < n; i++) {
		for (int j = i + final; j < n; j++) {
			if (v[j] <= p * v[i]) {
				tmp = j - i + 1;
				if (tmp > final)final = tmp;
			}
			else break;
		}
	}
	cout << final;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值