Cup(计算几和)


Cup

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4281    Accepted Submission(s): 1347


Problem Description
The WHU ACM Team has a big cup, with which every member drinks water. Now, we know the volume of the water in the cup, can you tell us it height?

The radius of the cup's top and bottom circle is known, the cup's height is also known.
 

Input
The input consists of several test cases. The first line of input contains an integer T, indicating the num of test cases.
Each test case is on a single line, and it consists of four floating point numbers: r, R, H, V, representing the bottom radius, the top radius, the height and the volume of the hot water.

Technical Specification

1. T ≤ 20.
2. 1 ≤ r, R, H ≤ 100; 0 ≤ V ≤ 1000,000,000.
3. r ≤ R.
4. r, R, H, V are separated by ONE whitespace.
5. There is NO empty line between two neighboring cases.

 

Output
For each test case, output the height of hot water on a single line. Please round it to six fractional digits.
 

Sample Input
  
  
1 100 100 100 3141562
 

Sample Output
  
  
99.999024
 

Source
The 4th Baidu Cup final



意解: 这种精度的问题最坑爹了,一定要注意取足够的精度,不然为WA的; 题目可以直接二分答案(二分杯子的高度),接下来就是求圆台的体积问题了,具体看下代码吧


#include <cstdio>
#include <cmath>
#define pi acos(-1.0)//圆周率
#define exp 1e-9 //精度

double  gets(double h, double H, double r, double R)
{
    double k = h / H * (R - r) + r; //根据三角形的相识原理求出当前高度的上底的圆的半径;
    return pi / 3.0 *(r * r + r * k + k * k) * h;//圆台的体积等于三分之一高乘于上底和下底的面积在加上上底和下底的乘积的开方;
}

int main()
{
   int T;
   double r,R,h,H,V;
   scanf("%d",&T);
   while(T--)
   {
       scanf("%lf %lf %lf %lf",&r,&R,&H,&V);
       double ua,ub;
       ua = 0;
       ub = H;
       while(ua < ub)
       {
           h = (ua + ub) / 2.0;
           double sum = gets(h,H,r,R);
           if(sum < V) ua = h + exp; //当前的水体积小于原本的体积,则高度不够,缩小区间
           else ub = h - exp;
       }
       printf("%.6lf\n",ua);
   }
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值