Girls and Boys(二分图匹配)


E -
Girls and Boys
Time Limit:5000MS    Memory Limit:10000KB    64bit IO Format:%I64d & %I64u

Description

In the second year of the university somebody started a study on the romantic relations between the students. The relation "romantically involved" is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been "romantically involved". The result of the program is the number of students in such a set.

Input

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1 (n <=500 ), for n subjects.

Output

For each given data set, the program should write to standard output a line containing the result.

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output

5
2

题意: 题目说的是一个学生的研究活动,说的是研究男女的烂漫生活,然后便列出了一些学生之间的关系,叫你找出一个最大的集
合,而在这个集合中的任意两个学生都没有一起共事研究男女之间的烂漫;

意解: 题目是一个裸的二分图求最大独立集,根据最大独立集=定点数 - 最大匹配数,便可以用匈牙利算法解决了;
         不过需注意一点,因为题目没有分清男女,所以在不是二分图,不过我们可以把其看成二分图,把人一分二看
         ,最终的结果除以2即可.

AC代码:

           
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>

using namespace std;
int vis[550],mack[550];
vector<int>G[550];

/*******************************/
/* 最大独立集 = 定点数 - 最大匹配数;*/

int find(int u)
{
    for(int i = 0; i < G[u].size(); i++)
    {
        int ue = G[u][i];
        if(!vis[ue])
        {
            vis[ue] = 1;
            if(mack[ue] == -1 || find(mack[ue]))
            {
                mack[ue] = u;
                return 1;
            }
        }
    }

    return 0;

}

int main()
{
    //freopen("in.txt","r",stdin);
    int n;
    while(~scanf("%d",&n))
    {
        int res = 0;
        memset(mack,-1,sizeof(mack));
        for(int i = 0; i <= 500; i++)
            G[i].clear();
        for(int pos = 0; pos < n; pos++)
        {
            int i,x,y;
            scanf("%d: %*c%d%*c",&i,&x);
            while(x--)
            {
                scanf("%d",&y);
                G[i].push_back(y);
            }
        }

        for(int i = 0; i < n; i++)
        {
            memset(vis,0,sizeof(vis));
            if(find(i)) res++;
        }

        printf("%d\n",n - res / 2);
    }

    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值