Girls and Boys(二分图--匈牙利算法)

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12197 Accepted Submission(s): 5743

Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 …
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.

Sample Input
7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output
5
2

Source
Southeastern Europe 2000

基础匈牙利算法~

最大独立集指的是两两之间没有边的顶点的集合,顶点最多的独立集成
为最大独立集。二分图的最大独立集=节点数-(减号)最大匹配数。

#include<bits/stdc++.h>
using namespace std;
int n;
int ma[512][521];
int match[511];
int v[511];
int dfs(int u)
{
    for(int i=0;i<n;i++)
    {
        if(ma[u][i]==1&&v[i]==0)
        {
            v[i] = 1;//标记已经访问过了
            if(match[i]==-1||dfs(match[i]))//如果没有匹配过,或者找到了新的配对
            {
                match[i] = u;//更新配对关系
                return true;
            }
        }
    }
    return false;
}
int g()
{
    memset(match, -1, sizeof(match));//清为-1
    int sum = 0;//匹配数*2
    for(int u=0;u<n;u++)
    {
        memset(v, 0, sizeof(v));
        if(dfs(u))
            sum ++;
    }
    return sum;
}
int main()
{
    while(cin>>n)
    {
        memset(ma, 0, sizeof(ma));
        for(int i=0;i<n;i++)
        {
            int a, b;
            scanf("%d: (%d)", &a, &b);
            while(b--)
            {
                int c;
                scanf("%d", &c);
                ma[a][c] = 1;
            }
        }
      printf("%d\n", n - g()/2);//节点数-最大匹配数
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值