Leftmost Digit(对数,数论)

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14445    Accepted Submission(s): 5532


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
2 2

分析:

n^n=a.bcdegf.... * 10^m;   科学计数法

两边去对数:n*lg(n)=m+lg(a.bcdef...);(2)

因为在科学计数法中 1<=a<10,   所以 0<lg(a)<1;即,在(2)式中,lg(a.bcdef...)表示的是n*lg(n)的小数部分

code:

#include<stdio.h>
#include<iostream>
#include<math.h>
#include<algorithm>
using namespace std;
int main()
{
    int t;
    long long n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld",&n);
        //n*lg(n)=m+lg(a);//1<=a<10,所以0<lg(a)<1 ,即表示的是小数部分
        //(int)n*lg(n)//表示的是m,
        // (double)n*lg(n)//表示的是 lg(a),
        double j=(double)n*log(n*1.0)/log(1.0*10);
        long long k=(long long)n*log(n)/log(10);
        int ans=(int)pow(10.0,j-k);
        cout<<ans<<endl;
    }
    return 0;
数学是深造的科学!!!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值