H - Happy 2006

H - Happy 2006

Time Limit:3000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9...are all relatively prime to 2006.

Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order.

Input

The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).

Output

Output the K-th element in a single line.

Sample Input

2006 1
2006 2
2006 3

Sample Output

1
3
5
 
意解:题目简单易懂,但是要解决这道题目就需要费点功夫了.首先要知道如果一个数与另一个数的gcd不为1,则它们有公共的质因子,所以首先要先算出n的所有最小质
因子,然后分块,加容斥就可以了. 怎么分块呢? 可以这样理解,对于一段数的区间{l,r},可以知道有多少个跟n不互质,这个可以用容斥原理搞定,剩下的就是不断延长区间.
形如[l + x,r + y],这种形式;
具体看代码吧!

AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>

using namespace std;
typedef long long ll;

vector<int>tp;

int main()
{
    int n,k,t;
    while(~scanf("%d %d",&n,&k))
    {
        tp.clear();
        t = n;
        for(int i = 2; i * i <= n; i++)
        {
            if(t % i == 0)
            {
                tp.push_back(i);
                while(!(t % i))
                    t /= i;
            }
        }
        if(t != 1) tp.push_back(t);
        ll now,next,Len,ans;
        Len = tp.size();
        now = 1;
        next = now + k - 1;
        while(k)
        {
            ans = 0;
            for(int i = 1; i < (1LL << Len); i++)
            {
                int mul = 1,tmp = 0;
                for(int j = 0; j < Len; j++)
                    if((i >> j & 1)) mul *= tp[j],tmp++;
                if(tmp & 1) ans += next / mul - (now - 1) / mul;
                else ans -= next / mul - (now - 1) / mul;
            }
            k = k - (next - now + 1 - ans);
            if(!k) break;
            now = next + 1;
            next = now + k - 1;
        }
        printf("%I64d\n",next);
    }
    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值