Monkey and Banana(DAG上的动态规划问题)

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8122    Accepted Submission(s): 4194



Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
  
  
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
  
  
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342 题意: 有一群闲得无聊的科学家打算测试猴子的IQ,科学家想出了一个方法来测试猴子们. 首先科学家把猴子最喜欢吃的香蕉放在屋顶,在给它们n个种类的石块, 然后看看猴子们能不能利用这些石块拿到香蕉. 石块是一个矩形立方体,可以任意摆放,一个石块可以放在另一个石块的前提是石块的宽和长要严格大于另一个石块 的宽和长. 猴子现在叠石块,结果问猴子所能叠出的石块的最大高度为多少. 题解: 典型的DAG上的动态规划问题,一个石块可以叠在另一个石块时,就连一条有向边,然后就记忆化搜索从i个石块开始搜索的最大高度. AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <map>
#include <vector>
#include <cmath>
#include <cctype>

using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int M = 200;
int to,G[M][M],d[M];

struct Node
{
    int x,y,z;
    bool operator < (const Node &a) const
    {
        return a.x > x || (a.x == x && a.y > y);
    }
} p[M];

void make(int a,int b,int c) //石块可以有六种摆放方法;
{
    p[to].x = a;
    p[to].y = b;
    p[to++].z = c;
    p[to].x = b;
    p[to].y = a;
    p[to++].z = c;
    p[to].x = a;
    p[to].y = c;
    p[to++].z = b;
    p[to].x = c;
    p[to].y = a;
    p[to++].z = b;
    p[to].x = b;
    p[to].y = c;
    p[to++].z = a;
    p[to].x = c;
    p[to].y = b;
    p[to++].z = a;
}

int dp(int i) //记忆化搜索;
{
    int& ans = d[i];
    if(ans) return ans;
    ans = p[i].z;
    for(int j = 0; j < to; j++)
        if(G[i][j]) ans = max(ans,dp(j) + p[i].z);
    return d[i] = ans;
}

void debug() //调试用的;
{
    for(int i = 0; i < to; i++)
        printf("%d %d %d\n",p[i].x,p[i].y,p[i].z);
}

int main()
{
    int n,Max,cnt = 0;
    while(~scanf("%d",&n) && n)
    {
        to = Max = 0;
        memset(G,0,sizeof(G));
        memset(d,0,sizeof(d));
        while(n--)
        {
            int a,b,c;
            scanf("%d %d %d",&a,&b,&c);
            if(a == b && b == c)
            {
                p[to].x = a;
                p[to].y = b;
                p[to++].z = c;
                continue;
            }
            make(a,b,c);
        }
        //debug();
        for(int i = 0; i < to; i++)
            for(int j = 0; j < to; j++)
                if(i != j)
                    if(p[i].x < p[j].x && p[i].y < p[j].y) G[i][j] = 1; //建图
        for(int i = 0; i < to; i++)
            Max = max(Max,dp(i));
        printf("Case %d: maximum height = %d\n",++cnt,Max);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值